The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"mod_userdir" fails?

Discussion in 'General Discussion' started by bear, Dec 2, 2009.

  1. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Just moved an account to a server from another, and wanted to test by using IP/~username. This fails, and gives the default cpanel 404. tried with other accounts on this box, <<correction: most work>>. The mod_userdir tweak is not disabled/enabled (no check in any boxes), but I've tried both ways. In the error logs I get these:
    Code:
    [Wed Dec 02 09:40:30 2009] [error] [client *my IP*] File does not exist: /usr/local/apache/htdocs/~user
    [Wed Dec 02 09:40:30 2009] [error] [client *my IP*] File does not exist: /usr/local/apache/htdocs/~user, referer: http://serverIP/~user/
    User accounts are set up in /home, so where is it getting the idea to look in htdocs, and how to correct this? Any ideas would be most welcome.
     
    #1 bear, Dec 2, 2009
    Last edited: Dec 2, 2009
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Mod_userdir definitely must be set to enable. Turn off mod_userdir server wide (i.e. no check boxes should be selected) and it should work.
     
  3. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Unfortunately, it does not, and gives the same result with that tweak off or on and all points in between. It works for older accounts, but with somewhat newer accounts it appears to be looking in the htdocs directory, instead of bringing the visitor to the account as it usually did.
    I need to know why, and how to fix that.
     
Loading...

Share This Page