The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_userdir Tweak is not working ?

Discussion in 'General Discussion' started by heavypredator, Jul 11, 2003.

  1. heavypredator

    heavypredator Well-Known Member

    Joined:
    May 2, 2003
    Messages:
    93
    Likes Received:
    1
    Trophy Points:
    8
    cpanel bug+fix:mod_userdir Tweak is not working with hostname ?

    users can still use http://host.name.com/~user/

    mod_userdir Tweak is enabled

    to fix this enable userdir tweak and edit your httpd.conf
    vi /usr/local/apache/conf/httpd.conf

    find this:

    <VirtualHost **.**.**.**>
    BytesLog domlogs/host.name.com-bytes_log
    ServerName host.name.com
    DocumentRoot /usr/local/apache/htdocs
    </VirtualHost>

    and change to this:

    <VirtualHost **.**.**.**>
    BytesLog domlogs/host.name.com-bytes_log
    ServerName host.name.com
    <IfModule mod_userdir.c>
    Userdir disabled
    Userdir enabled ********
    Userdir enabled ********
    Userdir enabled ********
    </IfModule>
    DocumentRoot /usr/local/apache/htdocs
    </VirtualHost>


    instead of ********* put user wich you want to enable usage of http://host.name.com/~user/
     
    #1 heavypredator, Jul 11, 2003
    Last edited: Jul 11, 2003
  2. dthigpen

    dthigpen Active Member

    Joined:
    May 29, 2003
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Apex, NC
    Take out..

    Take out the global mod_userdir statement that's a bit higher up in your httpd.conf. That will fix your problem.

    cPanel.net Support Ticket Number:
     
  3. heavypredator

    heavypredator Well-Known Member

    Joined:
    May 2, 2003
    Messages:
    93
    Likes Received:
    1
    Trophy Points:
    8
    but will disable shared SSL :p

    my fix dont disable it - but it would be nice if developers would implemented it in next release

    cPanel.net Support Ticket Number:
     
  4. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
    Hehe.... strange way you have to solve things :D

    why dont select the GLOBAL select box...
    and then click to ALLOW it on your SHARED SSL domain ?

    this will work.
    I have userdir disabled on all domains, except one or two I use to show sites (using /~username ) that are not yet resolving to the IP. (in the meanwhile, people can see their websites using user_dir) So for you use with shared SSL is THE SAME :D

    Regards.

    cPanel.net Support Ticket Number:
     
  5. heavypredator

    heavypredator Well-Known Member

    Joined:
    May 2, 2003
    Messages:
    93
    Likes Received:
    1
    Trophy Points:
    8
    the problem is when you have user using your hostname not domains

    domains are blocked but hostname not - then bandwitch usage goes to your hostname :)

    cPanel.net Support Ticket Number:
     
  6. bradandersen

    bradandersen Active Member

    Joined:
    Oct 6, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    UserDir, what to do?

    Okay, running Cpanel Release 10.6.0-R147.

    I'd like to get user directories working because it usually takes DNS 2-3 days to update before a client can visit their site.

    I've run /scripts/rebuildhttpdconf

    *Calling this in the URL:
    http://www.networksynergies.biz/~bsa1
    --or--
    http://www.networksynergies.biz/~bsa1/

    *Gives me this in the log file (/etc/httpd/logs/error_log):
    [Fri Sep 2 15:57:19 2005] [error] [client 70.116.4.157] File does not exist: /home/netsyn/public_html/~bsa1
    --or--
    [Fri Sep 2 15:49:44 2005] [error] [client 70.116.4.157] File does not exist: /home/netsyn/public_html/~bsa1/

    *And this in the web-browser:
    Not Found
    The requested URL /~bsa1/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at www.networksynergies.biz Port 80

    Thanks for the help,
    Brad
     
Loading...

Share This Page