Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

mode_security

Discussion in 'Security' started by crazyaboutlinux, Mar 27, 2009.

  1. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    939
    Likes Received:
    0
    Trophy Points:
    66
    Hi

    how to check that we are running latest version of mode_security

    & if we running old the how can be update it ?

    thanks
    Nilesh
     
  2. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    1
    Trophy Points:
    166
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Look at WHM >> Manage Plugins and it will tell you the version number and if it is checked it should keep it updated.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    939
    Likes Received:
    0
    Trophy Points:
    66
    no , its not telling software version
     
  4. Yogeshk

    Yogeshk Member

    Joined:
    Oct 26, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    The view is as follows:-

    Name: modsecurity
    Author: cPanel Inc.
    Version: 1.9.1-2.6
    Description: mod_security Support !!BETA!! (This is deprecated. Use easyapache3 to install mod_security as it is now supported without having to use the addon interface in easyapache3)
     
  5. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    939
    Likes Received:
    0
    Trophy Points:
    66
    Hi Guy's

    i m sorry guys


    i have check our server & found that there isn't installed mod_security
    now please tell me how to install mod_security properly with config settings

    then it should be show under plugins menu.

    we are using :

    cPanel 11.24.4-R34387
    WHM 11.24.2 - X 3.9
    CENTOS 4.7 i686 on virtuozzo
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,571
    Likes Received:
    439
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Search the forums for threads concerning running Easy Apache. That's where you'd select and install Mod_Security now days. There are many threads about this topic to go thru that will help you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice