Modifiy RELEASE to CURRENT on file (I can't access to WHM)

speckados

Well-Known Member
Hi.

I like run upcp with CURRENT release instead RELEASE.

I can't access to WHM because error:

```
==> cpsrvd: Setting up SSL support ... cpsrvd: invalid SSL settings loaded from /var/cpanel/conf/cpsrvd/ssl_socket_args; using defaults at /usr/local/cpanel/Cpanel/SSLService.pm line 64.
Can't locate auto/Net/SSLeay/CTX_get0_pa.al in @INC (@INC contains: /usr/local/cpanel /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/530/lib/perl5/5.30.0/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/530/lib/perl5/5.30.0 /opt/cpanel/perl5/530/site_lib/x86_64-linux-64int /opt/cpanel/perl5/530/site_lib) at /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/IO/Socket/SSL.pm line 118.
```

I think is a problem because is a upgrade Cebntos6 to Centos 7. In all older machines (35) work fine, but in this get this problem

What file has configuration of WHM for change RELEASE to CURRENT ?

Tahnks.
 

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
405
93
328
cPanel Access Level
DataCenter Provider
Hello,

I believe it's controlled by /etc/cpupdate.conf Look at the CPANEL variable in that file. Having said that, you need to be very careful doing what you are trying to do. Right now both Current and Release (from cPanel's update servers point of view) are on 88.0.9. Your server, however may not be. going from current to release could "potentially" be a downgrade, and that is not supported.

I'd suggest opening a cPanel ticket and have them look at the SSL issue.