noimad1

Well-Known Member
Mar 27, 2003
626
0
166
I have a process called modprobe running, and it is taking up 95% cpu usage....I can not kill the process for the life of me. I keep trying, but it doesn't go anywhere....
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
Type in:

man modprobe

to find out what it is. You won't be able to kill it as it's attempting to load kernel modules. You'll probably have to reboot. If it recurs, you're going to have to investigate what kernel modules are being loaded and whether you need a new kernel from your OS vendor (presuming you haven't installed a custom kernel, 'cos then you are on your own).
 

d-woo

Well-Known Member
Aug 9, 2003
88
0
156
Same Modprobe issue

I had the same modprobe issue.

I rebooted and it has not recurred...so far.

**************************************************

the command man modprobe yielded the following info:


[email protected] [~]# man modprobe
MODPROBE(8) Linux Module Support MODPROBE(8)

NAME
modprobe - high level handling of loadable modules

SYNOPSIS
modprobe [-adnqv] [-C config] module [symbol=value ...]
modprobe [-adnqv] [-C config] [-t type] pattern
modprobe -l [-C config] [-t type] pattern
modprobe -c [-C config]
modprobe -r [-dnv] [-C config] [module ...]
modprobe -Vh

OPTIONS
-a, --all
Load all matching modules instead of stopping after the first successful loading.

-c, --showconfig
Show the currently used configuration.

-C, --config config
Use the file config instead of (the optional) /etc/modules.conf to specify the
configuration. The environment variable MODULECONF can also be used to select (and
override) a different configuration file from the default /etc/modules.conf (or
/etc/conf.modules (deprecated)).

When environment variable UNAME_MACHINE is set, modutils will use its value instead of the
machine field from the uname() syscall. This is mainly of use when you are compiling 64
bit modules in 32 bit user space or vice versa, set UNAME_MACHINE to the type of the
modules. Current modutils does not support full cross build mode for modules, it is
limited to choosing between 32 and 64 bit versions of the host architecture.

-d, --debug
Show information about the internal representation of the stack of modules.

-h, --help
Display a summary of options and immediately exit.

-k, --autoclean
Set 'autoclean' on loaded modules. Used by the kernel when it calls on modprobe to
satisfy a missing feature (supplied as a module). The -q option is implied by -k.
These options will automatically be sent to insmod.

-l, --list
List matching modules.

-n, --show
Don't actually perform the action, just show what would be done.

-q, --quiet
Do not complain about insmod failing to install a module. Continue as normal, but
silently, with other possibilities for modprobe to test. This option will
automatically be sent to insmod.

-r, --remove
:
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,217
4
193
Minneapolis, MN
d-woo said:
I had the same modprobe issue.

I rebooted and it has not recurred...so far.
**************************************************
the command man modprobe yielded the following info:

[email protected] [~]# man modprobe
MODPROBE(8) Linux Module Support MODPROBE(8)

NAME
modprobe - high level handling of loadable modules
To share some more ifnromation about modprobe, You can run the command: lsmod to see what modules are already loaded into the kernel which gets its information by reading the file /proc/modules.

When the kernel needs a feature that is not resident in the kernel, the kernel module daemon kmod[1] execs modprobe to load the module in.

Next, modprobe looks through the file /lib/modules/version/modules.dep, to see if other modules must be loaded before the requested module may be loaded. This file is created by depmod -a and contains module dependencies. For example, msdos.o requires the fat.o module to be already loaded into the kernel.

Finally, modprobe uses insmod to first load any prerequisite modules into the kernel, and then the requested module. modprobe directs insmod to /lib/modules/version/[2], the standard directory for modules. insmod is intended to be fairly dumb about the location of modules, whereas modprobe is aware of the default location of modules. So for example, if you wanted to load the msdos module, you'd have to either run:

insmod /lib/modules/2.5.1/kernel/fs/fat/fat.o
insmod /lib/modules/2.5.1/kernel/fs/msdos/msdos.o

or just run the command: modprobe -a msdos

Hope this helps :)
 
Thread starter Similar threads Forum Replies Date
S Server Management 7
D Server Management 3