modsecurity option disabled from whm

useradmin

Well-Known Member
Oct 8, 2004
107
0
166
INDIA
HI,

I amnable to see modsecurity option in plugin with whm11
what may be the problem?
i have reinstall modsec many times but still same.
 

mtindor

Well-Known Member
Sep 14, 2004
1,452
110
193
inside a catfish
cPanel Access Level
Root Administrator
HI,

I amnable to see modsecurity option in plugin with whm11
what may be the problem?
i have reinstall modsec many times but still same.
I'f you're running one of the latest Edge/Current/Release builds of Cpanel (the ones that have EasyApache3 in them), you no longer install Mod_Security (or Tomcat) via Plugins. Instead you compile and install them during the Apache Compile (WHM / Apache Update).

Mike
 

useradmin

Well-Known Member
Oct 8, 2004
107
0
166
INDIA
mod_sec disabled

hi,.



yes for that i recompiled apache and disabled modsec option and installed by plugin but still the same issue...
 

yapluka

Well-Known Member
Dec 24, 2003
301
2
168
France
cPanel Access Level
Root Administrator
yes for that i recompiled apache and disabled modsec option and installed by plugin but still the same issue...
You may want to just forget the plugin and recompile apache WITH mod_security enabled. Don't forget to check the option "uniqueid", btw.

mod_security is working just fine and the interface is still available in the Addons section :)
 

mtindor

Well-Known Member
Sep 14, 2004
1,452
110
193
inside a catfish
cPanel Access Level
Root Administrator
hi,.



yes for that i recompiled apache and disabled modsec option and installed by plugin but still the same issue...
Why would you disable it in the EA3 build (the new method) and instead try to install it via the Plugins section - If you read on these forums, building Apache with it using EA3 is the way to go.

Mike