Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ModSecurity: Rule processing failed

Discussion in 'Security' started by foxmedo, Dec 6, 2017.

Tags:
  1. foxmedo

    foxmedo Registered

    Joined:
    Apr 21, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all,

    we have migrate our server from EA3 to EA4 yesterday and we have a lot of problems with this new configuration


    this an example of the content of /usr/local/apache/logs/error_log
    [Wed Dec 06 21:34:17.906608 2017] [:error] [pid 18548:tid 139670904047360] [client xxx.xxx.xx.xx:xxxxx] [client xxx.xxx.xxx.xxx] ModSecurity: Rule processing failed (id=981138, msg=). [hostname "xxxxxxxxx.com"] [uri "/boutique/acer-19-5-led-k202hqlab/"] [unique_id "WihUSbhl0@LXe6clPozmVwAAABE"]

    i have check ModRuid2 and it's disable

    waiting for your help

    B.R
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,734
    Likes Received:
    1,706
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  3. foxmedo

    foxmedo Registered

    Joined:
    Apr 21, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    i have find a solution for this problem i don't know if it's really a solution

    i have create an account into site Account Login | Project Honey Pot
    i have generate API KEY and insert it into /etc/apache2/conf.d/modsec_vendor_configs/OWASP/modsecurity_crs_10_setup.conf

    now the problem doesn't apparate into the error_log is it a good solution or i have to disable the rule ??
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,734
    Likes Received:
    1,706
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    That looks to be a valid solution. It's discussed further at:

    Rule processing failed mod_cgi.c - ModSecurity

    Thank you.
     
Loading...

Share This Page