Modsecurity upgrade error: Libyajl

fast lane

Member
May 30, 2008
6
0
51
Hi, I'm getting the following error when trying to run easy apache. Cpanel will also not upgrade because of this. Any help please? Thanks!!

Code:
Error: Package: ea-apache24-mod_security2-2.9.3-4.4.4.cpanel.x86_64 (EA4)
Requires: libyajl.so.2()(64bit)
Error: Package: ea-apache24-mod_security2-2.9.3-4.4.4.cpanel.x86_64 (EA4)
Requires: yajl
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2020-03-23_14:00:39-1
I see the following in the cpanel changelog on Jan 29th this year:

Code:
mod_security2
EA-8753: Compile mod_security2 with yajl-devel for JSON.
Maybe there is a connection?
 

fast lane

Member
May 30, 2008
6
0
51
Saw this page, where folks state yajl is no longer maintained so CentOS and RHEL don't support it. But Cpanel bombs without it when mod security was updated. This prevents normal upgrades of Cpanel/whm.