The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Modules not workin when using /~username

Discussion in 'General Discussion' started by doct66, Jan 22, 2006.

  1. doct66

    doct66 Member

    Joined:
    Dec 17, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Been searching but couldn't find anything related.

    Say I create an account domain.com with username domain, then in the httpd.conf file, I enable a module inside <VirtualHost> such as mod_choke to limit number of connections per IP for this account. When visitor go to www.domain.com, the limitation is working, but when visitors go to http://IP/~domain/ , it's not working. Does anyone know how to set it so that the preview link also works. Thanks.


    PS, If I enable the module anywhere in httpd.conf outside virtualhost tag, it's working for preview link, but it also applies to all the accounts, which is causing more trouble.


    current virtual config for this account:

    <VirtualHost xxx.xxx.xxx.xxx>
    ServerAlias domain.com
    ServerAdmin webmaster@domain.com
    DocumentRoot /home3/domain/public_html
    BytesLog domlogs/domain.com-bytes_log
    ServerName www.domain.com
    User domain
    Group domain
    CustomLog /usr/local/apache/domlogs/domain.com combined
    ScriptAlias /cgi-bin/ /home3/domain/public_html/cgi-bin/

    <IfModule mod_choke.c>
    MaxConnectionsPerIP 10
    Choke On
    </IfModule>

    </VirtualHost>
     
    #1 doct66, Jan 22, 2006
    Last edited: Jan 22, 2006
  2. jdarow

    jdarow Well-Known Member
    PartnerNOC

    Joined:
    May 30, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Michigan, US
    cPanel Access Level:
    DataCenter Provider
    You could add the IfModule statement to the first virtual host entry.
     
  3. doct66

    doct66 Member

    Joined:
    Dec 17, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I did, it worked. Thanks.
     
Loading...

Share This Page