Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mongrel_rails execution error! help plz:-)

Discussion in 'General Discussion' started by psdjc, Aug 31, 2007.

  1. psdjc

    psdjc Registered

    Joined:
    Aug 17, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    Hi, guys.

    I installed ruby on rails on cpanel11(apache2/php5/mysql5)

    and trying to run & test ror with mongrel

    and i run this script on prompt

    ===========
    @mongrel_rails start -d

    and i got this error
    ============
    @/usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1-mswin32/lib/http11.so: /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1-mswin32/lib/http11.so: invalid ELF header - /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1-mswin32/lib/http11.so (LoadError)
    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `require'
    from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1-mswin32/lib/mongrel.rb:11
    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `gem_original_require'
    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `require'
    from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1-mswin32/bin/mongrel_rails:9
    from /usr/bin/mongrel_rails:16:in `load'
    from /usr/bin/mongrel_rails:16

    does anyone know the reason why this happen or what's wrong?

    Thanks.

    Have a nice day, all of you!
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice