The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Monitoring for Chilisoft ASP

Discussion in 'General Discussion' started by ozzi4648, Feb 9, 2003.

  1. ozzi4648

    ozzi4648 Guest

    Has anyone setup checksrvd to monitor for Chilisoft services? If so care to share?
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    We've only been able to get the admin side checked, since the client side doesn't use the ports in the same way, IE: cannot do a GET on them, we are still trying to get this part done.
     
  3. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    Okay we got it!

    You need to put a simple asp page in /usr/local/apache/htdocs and add your main server address to be able to use asp pages through the asp admin console.

    We use a simple asp page called count.asp it simple drops an incrementing number to screen.

    Then in /etc/chkserv.d create the following file called asp

    #SERVICE = PORT, SEND, RESPONSE, RESTART COMMAND
    service[ASP]=80,GET /count.asp HTTP/1.0,HTTP/1.1 200 OK.,/usr/local/chillisoft/asp-server-9999/caspctrl - stopall;/usr/local/chillis
    oft/asp-server-9999/caspctrl -startall

    Replace 9999 with appropriate number for your asp server.

    Now the way this works is simple. If asp pages are being served okay then it sends back a HTTP/1.1 200 OK, BUT if asp pages are failing the response is HTTP/1.1 501 ASP Service Disabled

    So when chkservd tries to get the count.asp page it is expecting a 200 OK, if it does not get that it initiates the stop and start of chillisoft.
     
  4. ozzi4648

    ozzi4648 Guest

    [quote:f7f5c41075][i:f7f5c41075]Originally posted by dgbaker[/i:f7f5c41075]

    Okay we got it!

    You need to put a simple asp page in /usr/local/apache/htdocs and add your main server address to be able to use asp pages through the asp admin console.

    We use a simple asp page called count.asp it simple drops an incrementing number to screen.

    Then in /etc/chkserv.d create the following file called asp

    #SERVICE = PORT, SEND, RESPONSE, RESTART COMMAND
    service[ASP]=80,GET /count.asp HTTP/1.0,HTTP/1.1 200 OK.,/usr/local/chillisoft/asp-server-9999/caspctrl - stopall;/usr/local/chillis
    oft/asp-server-9999/caspctrl -startall

    Replace 9999 with appropriate number for your asp server.

    Now the way this works is simple. If asp pages are being served okay then it sends back a HTTP/1.1 200 OK, BUT if asp pages are failing the response is HTTP/1.1 501 ASP Service Disabled

    So when chkservd tries to get the count.asp page it is expecting a 200 OK, if it does not get that it initiates the stop and start of chillisoft.

    [/quote:f7f5c41075]

    Can i kiss you? JOKE Let me try this and get back with. Thanks alot!
     
  5. ozzi4648

    ozzi4648 Guest

    What do you mean by this part?

    You need to put a simple asp page in /usr/local/apache/htdocs and add your main server address to be able to use asp pages through the asp admin console.

    We use a simple asp page called count.asp it simple drops an incrementing number to screen.
     
  6. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    You will notice in the asp file we call the following

    service[ASP]=80,GET /count.asp

    You need have an .asp file in htdocs. You can change count.asp to another one. Because remember in chkservd port 80 = htdocs directory. We chose one called count that is very quick.

    And then in ASP ADMIN console ensure that the server that uses htdocs can process asp pages.
     
  7. ozzi4648

    ozzi4648 Guest

    [quote:46039895ed][i:46039895ed]Originally posted by dgbaker[/i:46039895ed]

    And then in ASP ADMIN console ensure that the server that uses htdocs can process asp pages.[/quote:46039895ed]

    Right but what im unsure about is the above. Do you mean i need to create an applicate pointing to htdocs?

    Add application
    Application name* WHAT GOES HERE
    Directory* WHAT GOES HERE
    Please fill the required fields marked with asterisk (*).
     
  8. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    Oh! Okay, this is what I was meaning.

    Go into ASP admin, click on the Web Server tab, then go into virtual hosts, and make sure that the virtual server that has the docroot htdocs is selected.

    So if your server is server.domain.com ensure that is is checked to allow asp pages.

    Hope this helps.
     
  9. ozzi4648

    ozzi4648 Guest

    [quote:1024f243e5][i:1024f243e5]Originally posted by dgbaker[/i:1024f243e5]

    Oh! Okay, this is what I was meaning.

    Go into ASP admin, click on the Web Server tab, then go into virtual hosts, and make sure that the virtual server that has the docroot htdocs is selected.

    So if your server is server.domain.com ensure that is is checked to allow asp pages.

    Hope this helps.[/quote:1024f243e5]

    Oh sure, we have everthing checked. What is really annoying is when new sites are created by resellers and we have to manually check these sites every so often. Imagine when you have 50 resellers on one box who are terminating and creating accounts how time consuming this is.
     
  10. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    Hey ozzi - On another topic, do happen to have an Italian cpanel skin language file? I cannot seem to find one anywhere.
     
  11. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    Hey ozzi - On another topic, do happen to have an Italian cpanel skin language file? I cannot seem to find one anywhere.
     
  12. ozzi4648

    ozzi4648 Guest

    Negative. You have lots of Italians?
     
  13. ozzi4648

    ozzi4648 Guest

    On another note, that Chilisoft forums is a waste of time, it really is. Still cannot get DNS to work. Also, the spicepack test fails miserably. They said to uninstall and re install chilisoft but as many others have done this does not correct the problem. Amazing!
     
  14. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    Yea I know it's crap, I never get anything usefull from there.
     
  15. ozzi4648

    ozzi4648 Guest

    [quote:b4f26ad3fb][i:b4f26ad3fb]Originally posted by dgbaker[/i:b4f26ad3fb]

    You will notice in the asp file we call the following

    service[ASP]=80,GET /count.asp

    You need have an .asp file in htdocs. You can change count.asp to another one. Because remember in chkservd port 80 = htdocs directory. We chose one called count that is very quick.

    And then in ASP ADMIN console ensure that the server that uses htdocs can process asp pages.[/quote:b4f26ad3fb]

    Installed this according to your info. I have a green dot and chilisoft in my display. I then tested it. I stopped the asp server but the green never turned to red. Instead the apache monitor.

    Are you sure the stop and start commands are correct?

    /opt/casp/asp-server-3000/caspctrl - stopall run from the command line produces an error. It doesn't like - stopall. According to the help that pops up the syntax is just stopall or startall and not - stopall - startall. You can see the syntax by executing the following from the command line /opt/casp/asp-server-3000/caspctrl
     
  16. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    That's wierd the -stopall works on our box.

    /usr/local/chillisoft/asp-server-3026/caspctrl -stopall

    I took this directly from the /etc/init.d/asp-server-3026 script.

    As for the green light thing? I have noticed for almost everything it takes until the next check (8-9mins) before it would change color.
     
  17. ozzi4648

    ozzi4648 Guest

    [quote:16f802c9f7][i:16f802c9f7]Originally posted by dgbaker[/i:16f802c9f7]

    That's wierd the -stopall works on our box.

    /usr/local/chillisoft/asp-server-3026/caspctrl -stopall

    I took this directly from the /etc/init.d/asp-server-3026 script.

    As for the green light thing? I have noticed for almost everything it takes until the next check (8-9mins) before it would change color.[/quote:16f802c9f7]

    what is asp-server-3026? Its asp-server-3000 on our box. Did you execute /usr/local/chillisoft/asp-server-3026/caspctrl -stopall from the command line? What version are you running 3.6.2? Does your spicepack samples work? How about DSN tests?
     
  18. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    3026 is the port for asp

    ASP version 3.6.2L
    build number 1047

    Spice_packs don't seem to work

    Active Server Pages error 'ASP 0126'
    Include file not found
    /spicepack_samples/mail/getmail.asp, line 2
    The include file '/spicepack_samples/lib/funcs.asp' was not found.

    But the caspsamples work
    http://www.virtual-hosting.ca/caspsamp/default.asp
     
  19. ozzi4648

    ozzi4648 Guest

    [quote:a2d5aa25e8][i:a2d5aa25e8]Originally posted by dgbaker[/i:a2d5aa25e8]

    3026 is the port for asp

    ASP version 3.6.2L
    build number 1047

    Spice_packs don't seem to work

    Active Server Pages error 'ASP 0126'
    Include file not found
    /spicepack_samples/mail/getmail.asp, line 2
    The include file '/spicepack_samples/lib/funcs.asp' was not found.

    But the caspsamples work
    http://www.virtual-hosting.ca/caspsamp/default.asp
    [/quote:a2d5aa25e8]

    Hello, found the problem to Spicepack, DNS connection problems and the problem with being unable to run some of the samples.

    I stressed over this for days and days. I emailed Chilisoft repeatedly about the problem only to be told to uninstall and re install Chilisoft. That was fruitless. That certainly did not fix the problem and my error logs were free of any install errors.

    Found the problem in httpd.conf. I have noticed this problem on a number of Cpanel installations. For some unknown reason the following directive is not included in many of the Cpanel installations;

    ServerName host.name.com

    I could not beleive that Chilisoft relies of this directive to be in your httpd.conf or at least without it you will experience the above errors.

    Open httpd.conf

    Find the follow section:

    #
    # ServerName allows you to set a host name which is sent back to clients for
    # your server if it's different than the one the program would get (i.e., use
    # &www& instead of the host's real name).
    #
    # Note: You cannot just invent host names and hope they work. The name you
    # define here must be a valid DNS name for your host. If you don't understand
    # this, ask your network administrator.
    # If your host doesn't have a registered DNS name, enter its IP address here.
    # You will have to access it by its address (e.g., http://123.45.67.89/)
    # anyway, and this will make redirections work in a sensible way.
    #
    # 127.0.0.1 is the TCP/IP local loop-back address, often named localhost. Your
    # machine always knows itself by this address. If you use Apache strictly for
    # local testing and development, you may use 127.0.0.1 as the server name.
    #


    Now make sure that after the last # you have this, so now your setup looks like this:

    #
    # ServerName allows you to set a host name which is sent back to clients for
    # your server if it's different than the one the program would get (i.e., use
    # &www& instead of the host's real name).
    #
    # Note: You cannot just invent host names and hope they work. The name you
    # define here must be a valid DNS name for your host. If you don't understand
    # this, ask your network administrator.
    # If your host doesn't have a registered DNS name, enter its IP address here.
    # You will have to access it by its address (e.g., http://123.45.67.89/)
    # anyway, and this will make redirections work in a sensible way.
    #
    # 127.0.0.1 is the TCP/IP local loop-back address, often named localhost. Your
    # machine always knows itself by this address. If you use Apache strictly for
    # local testing and development, you may use 127.0.0.1 as the server name.
    #
    ServerName yourhost.name.com

    Substitue yourhost.name.com with the name of your hostname. Its the same name that is returned when you type;

    root@srv05 [/etc/httpd/conf]# hostname
    srv05.primenet.cc

    at the root prompt.

    Restart apache, test the Chilisoft samples, connection to DSN mysql databases, and spicepack samples should now all work.

    For spicepack make sure that spicepack components are enabled before testing by logging into the admin console.

    ;)
     
  20. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    Excellant work! Thanks for the tips.


    you the PM stuff on this site? It really sucks most of the time it says I cannot send anything for the 48 hours or so.
     
Loading...

Share This Page