The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

More tomcat woes

Discussion in 'cPanel Developers' started by bking, Jun 12, 2006.

  1. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    Since changing to MySQL 4.1, tomcat seems to have lost the ability to talk sql to the server. A user with their site coded in java, appears to show lots of errors in the logs such as:

    2006-06-13 05:13:58,378 ERROR TP-Processor11 - constructItem error
    java.lang.RuntimeException: Row does not exist. No row returned for executeSingleResult

    The section of their site that uses PHP, works.(the forums)

    I have rebuilt, tomcat, MySQL, httpd, php, and yet the errors persist and their main page is down (I have a redirect to their forums at the moment.)

    Anyone have any pointers, or experience a similar issue?
     
  2. chinhnt

    chinhnt Registered

    Joined:
    Aug 6, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I used to have the same problem, but you can look into the /etc/my.cnf and adjust accordingly

    Good luck
     
  3. kinglear

    kinglear Registered

    Joined:
    May 3, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem too

    after we upgrade to MySQL4.1, tomcat seems lost to talk to Mysql, which was working on MySQL4.0

    any clues please?
     
Loading...

Share This Page