Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Moved addon domain to another cPanel account. Now SSL does not work

Discussion in 'Security' started by joburg, Feb 8, 2019.

  1. joburg

    joburg Member

    Joined:
    Jun 30, 2017
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    CA
    cPanel Access Level:
    Website Owner
    hello,
    i had a domain name as an addon domain one cpanel account 1 from hosting company 1.
    after two weeks, i decided to move the domain to another cpanel account 2 with hosting company 2. i deleted the addon domain from cpanel 1 before i added the domain as an addon domain to cpanel 2. ssl was working fine while on cpanel 1. now that i am on cpanel 2, ssl has not worked, and it's been more than 24 hours. i can see .well-known folder and .htaccess file with "RewriteEngine on" declaration. when the site is accessed, it shows the chrome ssl warning and i have to click back to safety, etc. my application needs ssl to function else the api calls in my app does not work.

    1. is this happening because cpanel already issued an autossl for the domain name on cpanel 1 and now it won't issue it on cpanel 2, although these are two different hosting companies?

    2. any idea how i can get this working correctly?

    thanks a lot.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,829
    Likes Received:
    476
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you sure hosting company 2 permits AutoSSL? You might want to contact them to ask.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. joburg

    joburg Member

    Joined:
    Jun 30, 2017
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    CA
    cPanel Access Level:
    Website Owner
    Yes, they do.
    Thanks.
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    5,815
    Likes Received:
    443
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @joburg

    Most likely it is not, we reissue the certificates on the new provider when AutoSSL runs.


    This is something you're going to need to discuss with your provider. With the information provided as well as the information, you have access to we don't have enough to tell you why it's failing. Your provider should be able to get this sorted fairly easily for you though.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice