The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Moved to Apache suexec with phpsuxec and have a lot of problems

Discussion in 'EasyApache' started by Tiago, Oct 10, 2005.

  1. Tiago

    Tiago Member

    Joined:
    Aug 22, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hi,


    I moved to Apache suexec with phpsuxec and now I have a lot of problems with directory permissions:

    - Can't upload files with 777 get a Internal Server Error

    - Can't right in direcotries with 777


    How can I resolve this? :confused:


    Thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You cannot use directory or files permissions if you have phpsuexec enabled - that's one of the security aspects of it. You'll have to work around it or go back to the less secure way of calling php.
     
  3. Tiago

    Tiago Member

    Joined:
    Aug 22, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    How can I upload files then?
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    You'll have to disable Phpsuexec to chmod directories/files 777.
     
  5. Tiago

    Tiago Member

    Joined:
    Aug 22, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Thats the only solution?

    Its strange because have some domains where uploads work fine...
     
  6. Tiago

    Tiago Member

    Joined:
    Aug 22, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Another question.

    What are the correct file permissions for suexec?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The same as for phpsuexec, the CGI script must be chmod no higher that 755 and the directory that they're within should be no higher than 755.

    I don't understand your upload question. You upload files as you always would do, via FTP. IF you still have old files that are owned by nobody:nobody you need to chown them under the root account to user:user instead.
     
  8. Tiago

    Tiago Member

    Joined:
    Aug 22, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Sorry for the confusion.

    My problem is with normal upload scripts written in PHP.
     
Loading...

Share This Page