Moving from Redhat 7.2 => 9, ApacheSSL can't be started

Stephen

Active Member
Aug 14, 2001
39
1
308
I just moved one server from Redhat 7.2 to Redhat 9 and couldn't get apache with ssl to start.

Code:
[email protected] [/]# /etc/rc.d/init.d/httpd startssl
..
..
Apache:mod_ssl:Error: Private key not found.
**Stopped
/etc/rc.d/init.d/httpd startssl: httpd could not be started
I have digged through search engines but unfortunately have not been able to find a solution.

Configuration is correct in httpd.conf and keys and certs are tarred and moved over.

Any hint to the solution is greatly appreciated.

Error from apache log:
Code:
[Wed Aug 13 20:24:58 2003] [notice] caught SIGTERM, shutting down
[Wed Aug 13 20:25:03 2003] [error] mod_ssl: Init: Private key not found (OpenSSL library error follows)
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D094068:asn1 encoding routines:d2i_ASN1_SET:bad tag
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D09A00D:asn1 encoding routines:d2i_PrivateKey:ASN1 lib
cPanel.net Support Ticket Number: not yet opened

cPanel.net Support Ticket Number:
 

vishal

Well-Known Member
Jan 28, 2003
340
0
166
India
Originally posted by Stephen
I just moved one server from Redhat 7.2 to Redhat 9 and couldn't get apache with ssl to start.

Code:
[email protected] [/]# /etc/rc.d/init.d/httpd startssl
..
..
Apache:mod_ssl:Error: Private key not found.
**Stopped
/etc/rc.d/init.d/httpd startssl: httpd could not be started
I have digged through search engines but unfortunately have not been able to find a solution.

Configuration is correct in httpd.conf and keys and certs are tarred and moved over.

Any hint to the solution is greatly appreciated.

Error from apache log:
Code:
[Wed Aug 13 20:24:58 2003] [notice] caught SIGTERM, shutting down
[Wed Aug 13 20:25:03 2003] [error] mod_ssl: Init: Private key not found (OpenSSL library error follows)
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D094068:asn1 encoding routines:d2i_ASN1_SET:bad tag
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
[Wed Aug 13 20:25:03 2003] [error] OpenSSL: error:0D09A00D:asn1 encoding routines:d2i_PrivateKey:ASN1 lib
cPanel.net Support Ticket Number: not yet opened

cPanel.net Support Ticket Number:
Have you found the Soution for this :(
I am having the same issue and i cant upgrade coz i am on Latest Build s117.Though I m not moving for any RH version I am on Redhat 7.2 and everything was working fine and suddenly i got the message.

Thank you,

cPanel.net Support Ticket Number:
 
Last edited:

Stephen

Active Member
Aug 14, 2001
39
1
308
I took off all the installed certificates then installed a test cert, it worked so I then reinstalled one by one until I found the problem certificate and dropped it off.

I experienced the same problem as you months ago and the problem was,

in httpd.conf, search for these lines

<IfDefine SSL>
AddModule mod_ssl.c
</IfDefine>

You can open your httpd.conf and if you have those, comment out <IfDefine SSL> and </IfDefine> then restart apache, it will work for you.

cPanel.net Support Ticket Number: