The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mrtg

Discussion in 'cPanel Developers' started by TomNiq, Sep 11, 2004.

  1. TomNiq

    TomNiq Registered

    Joined:
    May 7, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    i have installed MRTG onto my server but for some reason the images do not show up. When i try to restart MRTG i get this error:

    WARNING: rateup died from Signal 11
    with Exit Value 0 when doing router 'mail-host-email-queue'
    Signal was 11, Returncode was 0
    libpng warning: Application was compiled with png.h from libpng-1.2.2
    libpng warning: Application is running with png.c from libpng-1.0.15
    gd-png: fatal libpng error: Incompatible libpng version in application and library

    Can someone help?

    Tom
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Quoted from another forum

    quote:
    --------------------------------------------------------------------------------
    Originally posted by DavidL
    service mrtg stop
    rpm -e --nodeps mrtg
    rpm -e --nodeps libpng10
    cd /usr/lib
    ln -s libpng.so.3 libpng.so.2
    cd to your directory your mrtg rpm is in
    rpm -Uvh mrtg-package-name.rpm
    service mrtg start
    --------------------------------------------------------------------------------

    That should work. (no sense rewriting what has already been written)
     
  3. TomNiq

    TomNiq Registered

    Joined:
    May 7, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    lol i got it working by restarting apache....i dunno what it was but thanks for your replies in both forums!
     
  4. exodux

    exodux Well-Known Member

    Joined:
    Apr 12, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brisbane, Queensland, Australia
    I had the same problem with the images not shownig with my MRTG stats, so what i did was right click on the image that didnt show, selected "Properties" and then viewed the file name, then went into ssh and type: locate file-name.png
    then copied the file-name.png to the directory where mrtg site is located and the image worked :D
     
  5. dethman

    dethman Well-Known Member
    PartnerNOC

    Joined:
    Jan 4, 2003
    Messages:
    120
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    DataCenter Provider
    1. cd /usr/lib
    2. mv libpng.so.2 libpng.so.2.OLD
    3. ln -s libpng.so.3 libpng.so.2
    4. /etc/init.d/mrtg stop
    5. 4. /etc/init.d/mrtg start

    And works again...
     

Share This Page