The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Multi PHP versions

Discussion in 'General Discussion' started by johnchristy, Apr 25, 2014.

  1. johnchristy

    johnchristy Active Member

    Joined:
    Mar 7, 2014
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    hi

    I got a CentOS 6.5 VPS with cpanel/whm

    I'm currently using nginx+apache therefore my php handler is fcgi. Currently I have only php v5.4, however there are some templates of mine which requires php 5.3. I checked multiple tutorials online but not sure how to setup PHP 5.3 and php 5.4 using fcgi handler (I should be able to select which version I should use) I checked a plugin called PHP selector, unfortunately they require suphp handler.

    Anyone can guide on how to have/use php v 5.3 and 5.4 on CentOS 6.5 (fcgi is a must because nginx requires fcgi)

    Thanks
     
    #1 johnchristy, Apr 25, 2014
    Last edited: Apr 25, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    There is no native support for multiple PHP versions at this time. Feel free to vote and add your input to the existing feature request for this:

    Allow to install multiple PHP 5.x versions | cPanel Feature Requests

    Note that you can use FCGI with PHP Selector and Cloud Linux as far as I know. Where do you see that it's only compatible with suPHP?

    Thank you.
     
  3. johnchristy

    johnchristy Active Member

    Joined:
    Mar 7, 2014
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello

    Thank you for the update..

    kindly refer Nixtree || NT PHP Selector

    Note : ntPHPselector plugin require SuPHP on the system; it will not work with any other PHP handlers for now.

    I also had a chat with so called "Systems Engineer" he also confirmed that they support only suphp at this moment.

    If there are any other alternate to run php 5.3 and 5.4 please let me know

    Thanks
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. johnchristy

    johnchristy Active Member

    Joined:
    Mar 7, 2014
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    hmm i need to purchase a monthly subscription.. i really dont have a need for cloud linux platform.. thank you for your input michael :)
     
Loading...

Share This Page