Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

MultiPHP additional custom .ini files

Discussion in 'EasyApache' started by bejbi, Apr 1, 2017.

Tags:
  1. bejbi

    bejbi Well-Known Member

    Joined:
    Jan 20, 2006
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    158
    Location:
    Poland
    cPanel Access Level:
    DataCenter Provider
    Hi,

    I try to add my additional .ini files to php (open_basedir.ini in my case with open_basedir paths)

    I created file: open_basedir.ini in directory: /opt/cpanel/ea-php71/root/etc/php.d/

    And this is something strange:

    After I copy this file, it will not show in phpinfo()

    After some times (I don't know exactly how log does it takes, but let's say: next day) it was visible in phpinfo():
    "Additional .ini files parsed" section shows my file: open_basedir.ini

    and in open_basedir section there was my path (read from my file).

    But question is: why it is such delay /cache ? or something else, and how can I ask apache to read my ini file immediately ?

    Even when I remove something from original files in this directory (/opt/cpanel/ea-php71/root/etc/php.d/) changes are not visible right now in public. Mybe it will help.

    I'm using CloudLinux and EA4.

    I don't have any php.ini or .user.ini file in this directory. If it matters ?

    How to force apache to read my ini file ?

    W.
     
  2. bejbi

    bejbi Well-Known Member

    Joined:
    Jan 20, 2006
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    158
    Location:
    Poland
    cPanel Access Level:
    DataCenter Provider
    I checked CloudLinux is not the problem - I disabled cageFS and it changes nothing. I have the same problem.
     
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Are you sure CageFS was fully disabled? You have to run the cagefsctl --update command any time you have modified php.ini, or you want to get new/updated software inside CageFS. Please also see this document:

    PHP Selector > Configuration > Setting Default Version and Modules
    PHP Selector > Configuration > Individual PHP.ini files

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice