multiphp choosing 7.2 enables 5.5.38

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
I have this problem in one server, when i choose php 7.2 it actually sets 5.5.38.
Hello @benito,

Can you let us know the step-by-step instructions you are using when reproducing this behavior? For instance, how are you choosing PHP version 7.2?

Thank you.
 

benito

Well-Known Member
Jan 8, 2004
414
19
168
Mar del Plata - Argentina
cPanel Access Level
Root Administrator
Twitter
Hello @benito,

Can you let us know the step-by-step instructions you are using when reproducing this behavior? For instance, how are you choosing PHP version 7.2?

Thank you.
Hello Michael, i login into any customer cpanel, go to MultiPHP manager, check the desired domain, select php version and apply.

It works ok with all php versions except php 7.2.

This problem happens in one of 5 servers.

Thanks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello Michael, i login into any customer cpanel, go to MultiPHP manager, check the desired domain, select php version and apply.
Hello @benito,

I've been unable to reproduce this behavior on a test system. Do you notice any specific output to /usr/local/cpanel/logs/error_log when you reproduce the problem?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463

benito

Well-Known Member
Jan 8, 2004
414
19
168
Mar del Plata - Argentina
cPanel Access Level
Root Administrator
Twitter
Hello Michael!

I'm back with this. To answer your last question, we do not use LSWS.

Today we found this problem again when we changed the server default PHP version to 8.0.

In a very few customers when we choose INHERIT or ea-php80 the change looks ok in cPanel Interface but phpinfo() and apps shows its running with PHP Version 5.5.38

Thanks
 

benito

Well-Known Member
Jan 8, 2004
414
19
168
Mar del Plata - Argentina
cPanel Access Level
Root Administrator
Twitter
Yes! Looks like we have alt-php still running on that server. (We disabled alt-php from cPanel UI a couple of years ago).

This user was pretty old and have php 5 selected in alt-php

So, If the user doesn't use PHP Selector, you need to always have the Native version in PHP Selector, otherwise the PHP Selector version will overlap when the system version is selected.

They ran:

selectorctl --set-user-current=native --user=#username#

And problem solved!
 
  • Like
Reactions: cPRex