Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MultiPHP INI Editor empty "content"

Discussion in 'General Discussion' started by PatrickVeenstra, Apr 15, 2018.

  1. PatrickVeenstra

    PatrickVeenstra Well-Known Member

    Joined:
    Feb 12, 2012
    Messages:
    103
    Likes Received:
    3
    Trophy Points:
    68
    Location:
    Barcelona
    cPanel Access Level:
    Root Administrator
    I want to remove my custom php.ini created from the MultiPHP INI Editor, but I get this message (after deleting all text): The “content” argument cannot be empty.

    It actually looks like a bug to me but is it?
     
    #1 PatrickVeenstra, Apr 15, 2018
    Last edited: Apr 15, 2018
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @PatrickVeenstra,

    Can you let us know the full steps you are using to reproduce this issue? For instance, what specific entries did you add to the "Editor Mode" tab in "MultiPHP INI Editor"? Also, are you using this option in cPanel or in Web Host Manager?

    Thank you.
     
  3. PatrickVeenstra

    PatrickVeenstra Well-Known Member

    Joined:
    Feb 12, 2012
    Messages:
    103
    Likes Received:
    3
    Trophy Points:
    68
    Location:
    Barcelona
    cPanel Access Level:
    Root Administrator
    - enter CPanel
    - click MultiPHP INI Editor
    - click tab "Editor mode"
    - select a location
    - remove existing text (empty the "textarea")
    Code:
    ; cPanel-generated php ini directives, do not edit
    ; Manual editing of this file may result in unexpected behavior.
    ; To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
    ; For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)
    
    auto_prepend_file = "/home/account/domain/checkdomain.php"
    
    - click save

    p.d. I only wrote the last line when I "created" that file from within CPanel.
     
    #3 PatrickVeenstra, Apr 16, 2018
    Last edited: Apr 16, 2018
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @PatrickVeenstra,

    Thank you for the additional information. I've now reproduced this issue on a test system. Internal case CPANEL-8253 is open to address the issue where using "Editor Mode" in the MultiPHP INI Editor interface fails with the following error message when attempting to remove all custom entries:

    I'll monitor this case and update this thread with more information on it's status as it becomes available. In the meantime, the workaround is to manually remove the custom entries from the php.ini, .user.ini, and .htaccess files in the corresponding document root using SSH or File Manager.

    Thank you.
     
Loading...

Share This Page