The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Multiple Cpanel Servers and Exim

Discussion in 'General Discussion' started by kris1351, Jul 31, 2003.

  1. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We have several Cpanel servers running, but if you try to send mail from one to the other it fails. An example is when you run any script that sends as nobody or root from server 2 to the main server it gives you an undeliverable notice. The only catch is that the undeliverable notice actually gets delivered to the support address on the main server.

    cPanel.net Support Ticket Number:
     
  2. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    I am getting this also. Example .. my billing system sends mail as "nobody". When it (running on my server) sends to other domains I host on my other cpanel server ..or visa versa .. I get a email back from nobody@mybox

    550 Sender verify failed.

    someone@hosted-on-cpanel-box.com
    SMTP error from remote mailer after RCPT TO:<somebody@hosted-on-coanl-box.com>:
    host hosted-on-cpanel-box.com [xxx.xxx.xxx.xxx]: 550-Verification failed for <nobody@mybox.serverdomain.com>
    550-unrouteable mail domain "mybox.serverdomain.com"
    550 Sender verify failed



    Been like this for some time. It could have to do with the fact that this was a moved account. I have not tested on new accounts created on new servers.

    Bump .. bump .. bump..

    anyone know??

    cPanel.net Support Ticket Number:
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    bump ....

    cPanel.net Support Ticket Number:
     
  4. coastinc

    coastinc Well-Known Member

    Joined:
    Mar 13, 2002
    Messages:
    159
    Likes Received:
    0
    Trophy Points:
    16
    Do you have the option "Prevent the user 'nobody' from sending out mail to remote addresses" under "Tweak Settings" in WHM turned off?

    cPanel.net Support Ticket Number:
     
  5. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    nope not using that feature. The sending server uses nobody to send out. But also I just tested this with standard smtp and the same thing happens.

    cPanel.net Support Ticket Number:
     
  6. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Problem fixed. I know why now.

    My problem was when I tried to send mail using one server to another, using the SMTP of that server I got a returned 550 error. It only happend in one direction here is why.

    my servers share a domain name like this.

    server1.mymaindomain.com
    server2.mymaindomain.com

    mymaindomain.com has DND servers at the NIC associated with the nameservers hosted on "server1". That's becuase the domain "mymaindomain.com" is hosting also on "server1".


    Well when I built and set up "server2" I had to set up the A entry for the servename. When you do that the main domain "mymaindomain.com" gets set as authorative from inside that particular server. Well that domain record certainly contained a A entry for "server2" but had no reson to include a A entry for "server1" since it didn't know about the other server. Well what exim does is try to "lookup" sending domain when it delivers mail. Well when the email coming from "server1.mymaindoimain.com" came in exim went to lookup the dns zone for it. Seeing that "mymaindomain.com" was listed in it's own dns server it say it as authorative and looked no further. HOWEVER it saw no entry for "server1" on that record so it assumed (exim) saw it as a faked email. My solution was to add a A entry for "server1" and use the proper IP that belonged to server1.

    If I remember corectly, since I use several different domains for nameserver for each server (to keep from having all eggs in one dns basket) .. but I use a shared main domain for server names... what would happen is the hostname lookup would fail in the WHM all the time. So I added the zone. It wasn't complete.

    I am wondering if anyone knows of a better way to set this up? I am thinking of a differet domain for each box from now on.

    cPanel.net Support Ticket Number:
     
  7. cheapo

    cheapo Member

    Joined:
    Sep 6, 2002
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    i'm having the same problem. Neither of the above solutions apply. I don't have the "prevent nobody" box checked. i don't have the same domain for the 2 servers either.

    cPanel.net Support Ticket Number:
     
  8. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    Let's say the "sending" mail server's hostname is "sending.server.com" ..... when you are logged into "rec.theotherserver.com" and do a dig for "sending.server.com" does zone exist on that box or does it look elsewhere for the zone? also make sure you have reverse dns for sending box working.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page