The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

multiple domains to use servers ssl cert

Discussion in 'General Discussion' started by maggot96, Apr 9, 2009.

  1. maggot96

    maggot96 Member

    Joined:
    Apr 9, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I am an ex Plesk user, and have just moved over to Cpanel.
    In Plesk we were able to allow any domains added to the system using the shared IP to use the server's certificate for their own https pages, and it didnt have to be in the form of https://www.server.com/~userssite it was in the form of https://www.userssite.com and worked perfectly. Of course it gave browser warnings of the certificate not matching the domain name, but for testing the site and admin pages that the public will never see it was an invaluable feature. I have searched the net and cannot seem to find a difinitive answer about whether this sort of thing is possible in Cpanel/WHM? Is it even possible with a manually made self signed certificate for each different domain added to WHM/Cpanel? If so any idea how to do it? I get nothing but "500 internal server error's" everytime I try.
    Any help is greatly appreciated
     
  2. Ricardo-san

    Ricardo-san Member

    Joined:
    Apr 7, 2009
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    It works for me. You can try generating a cert in WHM and adding it to the domain.
    Can you post your error log?
     
  3. maggot96

    maggot96 Member

    Joined:
    Apr 9, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    The error log doesnt show anything to do with the 500 error for some reason.
    Nor does the access log. The ssl access log only shows the browser trying to get the 404 page to display but failing (even though it does not show any errors for this in the error log).
    Could you talk me through the procedure you used to get it to work. I assume you mean the self signed option works for you and not the same certificate for several domains option.
    Also I have been doing certificate adding things with the reseller or root account. could this be causing the problem?
     
Loading...

Share This Page