The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Multiple IP for sending mails

Discussion in 'E-mail Discussions' started by pjssms, May 28, 2008.

  1. pjssms

    pjssms Member

    Joined:
    Mar 24, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    In the new version 11.23 you have

    Exim send mail using the IP address dedicated to an account

    How does this works ?.
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    You can enable this by going to WHM -> Service Configuration -> Exim Configuration Editor and for the setting "** Send outgoing mail from accounts ip address instead of the main ip address. [Warning: If you turn this setting on you should make sure your reverse dns entries match the ones in /etc/mail_reverse_dns]", check that entry. Be sure to heed the warning in that message.

    Now whenever a user connects to send mail, whatever IP address is associated with that user is used as the IP address sending the mail rather than the server's primary IP address (if they are different).
     
  3. alan-tor

    alan-tor Active Member

    Joined:
    Dec 7, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    This is good news.

    Will this work for mail forwarders as well?

    Will it work for scripts sending mail via Sendmail, or only via SMTP?
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I believe it will work for scripts using SendMail as that ultimately goes through Exim anyway, though I am not certain on that offhand.

    This only works for outbound mail (mail SENT from your server), not inbound mail (such as forwarders).
     
  5. alan-tor

    alan-tor Active Member

    Joined:
    Dec 7, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Okay, please let us know when you find out about Sendmail.

    If it works only on SMTP, then I should set my own installation of SquirrelMail to use SMTP to send outgoing mail, instead of Sendmail. I want mail sent from my installation of SquirrelMail to use my reseller IP, not the server IP.

    So when a message arrives and is then sent outbound to an outside address by a cPanel mail forwarder, it won't use the user account's IP address? Forwarded mail will still use the shared server IP?
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I spoke to one of our techs, sendmail should use the same IP.

    Inbound mail will use whatever IP the A record of the MX record points to. So for example, if your MX record points to mx.example.com and the A record indicates the example.com has its own dedicated IP address, it would show up as coming from that dedicated IP address rather than the server's main IP address.
     
  7. alan-tor

    alan-tor Active Member

    Joined:
    Dec 7, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Interesting. Thank you very much for that information.
     
  8. Haloweb

    Haloweb Well-Known Member

    Joined:
    Jul 2, 2004
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Hi

    I have been waiting for this specific function for ever, thank you cpanel :)

    Please could you tell me how to achieve the following

    [Warning: If you turn this setting on you should make sure your reverse dns entries match the ones in /etc/mail_reverse_dns]
     
  9. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Just double-check the Reverse DNS records match what's in that file.

    Note, the vast majority of data centers do not let you manage your own Reverse DNS so you would likely be best asking them for advice regarding any Reverse DNS issues.
     
  10. deanstev

    deanstev Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    0
    can anyone tell me why sending email to some external domains fails when enabling this option? disabling it lets the email go straight through...

    The return message is:
    SMTP error from remote mail server after HELO :
    host their.mailserver.tld [XX.XXX.XXX.XX]: 501 HELO requires domain address
     
  11. Haloweb

    Haloweb Well-Known Member

    Joined:
    Jul 2, 2004
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    cPanelDavidG thank you, I contacted my DC and they soughted it out for me :)
     
  12. deanstev

    deanstev Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    0
    cPanelDavidG, can you help?
     
  13. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I'm not a support technician, but I recommend making sure reverse DNS is set up for that IP and that the reverse DNS matches what is in the file mentioned for that Tweak Setting.


    Remember, most data centers do not permit you to manage your own reverse DNS.
     
  14. deanstev

    deanstev Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    0
    Yes, all my IP's have rDNS (as set by my provider)
     
  15. deanstev

    deanstev Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    0
    Does anyone have any idea why the file keeps getting over-written?
     
Loading...

Share This Page