Multiple-table update/delete commands are not supported

RustyB

Registered
May 9, 2019
1
0
1
USA
cPanel Access Level
Root Administrator
After upgrading from MariaDB 10.1 to 10.3, I began receiving the following error when running an update statement. "Multiple-table UPDATE/DELETE commands are not supported". This update always ran fine before. I searched for this error online and could not find one instance of it. It is also important to note that I only get this error if running an update on a Maria table in which the source is a CONNECT table (in my case SQL Server). My OS is Debian 8, and I've installed unixODBC and FreeTDS. I can select from the CONNECT table fine. But when I use it in an update, I get the above error. Note again, I am not trying to Update the SQL Server CONNECT table. I just use is as a source in my UPDATE query. What would have changed from MariaDB 10.1 to 10.3 that would cause this to stop working all of a sudden?