The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

munin apache_processes plugin not working

Discussion in 'General Discussion' started by Vladimir Šebez, May 10, 2016.

Tags:
  1. Vladimir Šebez

    PartnerNOC

    Joined:
    May 5, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Belgrade, Serbia
    cPanel Access Level:
    Root Administrator
    Hi,

    It looks like since the last update this munin plugin has stopped working. Here is what I got from /var/log/munin/munin-node.log
    Code:
    2016/05/03-03:43:50 [755966] Error output from apache_processes:
    2016/05/03-03:43:50 [755966]    "my" variable @PORTS masks earlier declaration in same scope at /etc/munin/plugins/apache_processes line 171.
    2016/05/03-03:43:50 [755966]    syntax error at /etc/munin/plugins/apache_processes line 164, near "$type qw "busy idle""
    2016/05/03-03:43:50 [755966]    syntax error at /etc/munin/plugins/apache_processes line 169, near "}"
    2016/05/03-03:43:50 [755966]    Global symbol "$port" requires explicit package name (did you forget to declare "my $port"?) at /etc/munin/plugins/apache_processes line 174.
    2016/05/03-03:43:50 [755966]    syntax error at /etc/munin/plugins/apache_processes line 192, near "}"
    2016/05/03-03:43:50 [755966]    Execution of /etc/munin/plugins/apache_processes aborted due to compilation errors.
    2016/05/03-03:43:50 [755966] Service 'apache_processes' exited with status 255/0.
     
  2. dexus

    dexus Well-Known Member

    Joined:
    Jan 14, 2006
    Messages:
    169
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hello,

    Is there any news about this issue. Can someone from cPanel please respond.

    I see that plugin file is modified at 2016-04-20 20:38. Here are the details...

    Code:
      File: `/usr/local/cpanel/3rdparty/share/munin/plugins/apache_processes'
      Size: 5473  Blocks: 16  IO Block: 4096  regular file
    Device: fd04h/64772d  Inode: 5507025  Links: 1
    Access: (0755/-rwxr-xr-x)  Uid: (  0/  root)  Gid: (  0/  root)
    Access: 2016-05-19 07:40:02.000000000 +0200
    Modify: 2016-04-20 20:38:30.000000000 +0200
    Change: 2016-04-27 07:29:26.000000000 +0200
    
     
  3. garconcn

    garconcn Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    98
    Likes Received:
    1
    Trophy Points:
    8
    I noticed the same problem 2 weeks ago. The problem only happen on v56. I thought it was due to the perl change on v56.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,767
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Functionality with Munin and the apache_processes plugin is discussed as part of internal case CM-1738 and should be addressed with Munin update discussed at:

    Update to Munin to the most current version.

    I'll update this thread with more information as it becomes available.

    Thank you.
     
Loading...

Share This Page