marcochiesi

Member
Mar 1, 2011
24
1
53
Italy
cPanel Access Level
Root Administrator
Twitter
Hello,
I am running WHM 11.28.86 on a Centos 5.5 x86_64 virtuozzo VPS and I installed Munin 1.4.5.
Munin is running almost fine, but I am experiencing problems with some of the graphs:
  • Exim mail throughput: this graph is empty and the values are set to nan (the other exim graph is ok)
  • Munin processing time: this graph is empty and the values are set to nan
  • MySQL isam/myisam table-space usage: this graph is broken, the images doesn't show up, and if I try to access the direct url of the image I receive a 404 as the following:
    Not Found
    The server was not able to find the document (./munin/it/myserver.com/mysql_isam_space_-day.png) you requested.
    Please check the url and try again. You might also want to report this
    error to your web hosting provider.
    Note: all the other mysql graphs are working fine
  • Mailman usage: this graph is empty and the values are set to nan (I suppose this is normal since mailman is disabled)

I have read many munin discussions on this forum and also elsewhere, and I tried with several attempts of fixing these issues but without success.
Does anybody have suggestions?
 

Defected

Member
Dec 14, 2009
17
0
51
I'm facing same issues with munin on a fresh installed rhel 5.6 server. cPanel's support said that its probably a munin bug, but i can't reproduce it on other servers i' running.
 
Last edited:

Gadge

Registered
Oct 30, 2003
2
0
151
Buckingham UK
Having just replaced a server over the weekend and installed Munin plugin from WHM, I later discovered certain graphs were blank as described and with 'nan' values. I then compared /var/lib/munin/plugin-state with another server and found that the folder was empty and set with incorrect permissions (0755) by the installation.

Munin seems to require /var/lib/munin/plugin-state folder to be set with 0775 perms and, after doing so, the folder became populated with the necessary files at the next cron event. The created files should also have 0664 perms and I changed ownership of them to be 'munin'. After another couple of refreshes I had graphs appearing and 'nan' values had been replaced ...

Hope this helps?