The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Munin Install fails on cPanel DNSOnly

Discussion in 'Bind / DNS / Nameserver Issues' started by WhiteDog, Jan 5, 2013.

  1. WhiteDog

    WhiteDog Well-Known Member

    Joined:
    Feb 19, 2008
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    Trying to install Munin on a freshly installed cPanel DNSOnly Server (VPS) quickly fails:
    Code:
    Updating munin....
    
    Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/munin-Linux-x86_64/.cpanelsync.lock (connected:0).......(request attempt 1/12)...Using dns cache file /root/.HttpRequest/httpupdate.cpanel.net......searching for mirrors (mirror search attempt 1/3)......loaded mirror speeds from cache......mirror search success......connecting to 208.74.125.43...@208.74.125.43......connected......receiving......request success......Done
    Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/munin-Linux-x86_64/.cpanelsync.bz2 (connected:1).......(request attempt 1/12)...@208.74.125.43......connected......receiving...100%......request success......Done
    Checking for librrd version ...
    Done
    Adding munin user (if needed)...Done
    Installing perl modules....Log::Log4perl..[ok]..Module::Build..[ok]..Time::HiRes..[ok]..HTML::Template..[ok]..Net::Server..[ok]..Net::Server::Fork..[ok]..Net::SNMP..[ok]..HTML::Template..[ok]..Cache::Cache..[ok]..Done
    
    FYI: InnoDB access granted ok.
    Fixing rpath (if needed)...Done
    Extracting files...munin-1.4.7/
    munin-1.4.7/README.OSX
    munin-1.4.7/COPYING
    munin-1.4.7/logo.svg
    munin-1.4.7/UPGRADING
    munin-1.4.7/HACKING.pod
    
    .......
    
    cd plugins && /usr/local/bin/perl Build
    Building Munin::Plugins
    touch build-man-stamp
    mkdir -p build/doc
    for f in master/_bin/munin-graph master/_bin/munin-update master/_bin/munin-limits master/_bin/munin-html; do \
    	   pod2man --section=8 --release=1.4.7 --center="Munin Documentation" build/"$f" > build/doc/`basename $f`.8; \
    	done
    
    ERROR: Failed to install Munin - in ./install at munin source: make default target (): 
    Failed to make default target 
    Munin install process cannot proceed further ... 
    Exiting ...
    Failed to update munin
    For the record: Server is a VPS running CentOS 6.3 x64 with cPanel 11.34.0.11.

    I search high and low but could not find any similar topics.
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
  3. WhiteDog

    WhiteDog Well-Known Member

    Joined:
    Feb 19, 2008
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Hello Finn,

    Yes I stumbled on that thread myself but it's not a similar issue. The problem there (in the end) was caused by some weird IP resolving issue. I actually tried / checked most of the solutions in that thread. My issue however is not related to the thread you posted (as far as i'm aware).

    I should have said "I search high and low but could not find any topics with the exact same issue". But thank you none the less for your effort!
     
  4. ejsolutions

    ejsolutions Registered

    Joined:
    Jan 6, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    This isn't an isolated case, though in this case it's a full WHM installation.
    Newly installed CENTOS 6.3 x86_64 xenpv with WHM 11.34.1 (build 5)
    Default resolv.conf and host name resolving fine in DNS, along with hosts file amendment as above.
    Forced perl module install.
    Code:
    Creating new 'Build' script for 'Munin::Node' version '0.0.0'
    cd node && /usr/local/bin/perl Build
    Building Munin::Node
    cd plugins && /usr/local/bin/perl Build.PL
    Created MYMETA.yml and MYMETA.json
    Creating new 'Build' script for 'Munin::Plugins' version '0.0.0'
    cd plugins && /usr/local/bin/perl Build
    Building Munin::Plugins
    touch build-man-stamp
    mkdir -p build/doc
    for f in master/_bin/munin-graph master/_bin/munin-update master/_bin/munin-limits master/_bin/munin-html; do \
    	   pod2man --section=8 --release=1.4.7 --center="Munin Documentation" build/"$f" > build/doc/`basename $f`.8; \
    	done
    
    ERROR: Failed to install Munin - in ./install at munin source: make default target (): 
    Failed to make default target 
    
    I use munin extensively on other VPS nodes, so this is a pain - especially on a "default" installation. I am even considering tainting the repos. by adding EPEL and install/configure munin manually. I'd prefer not to resort to this.
     
    #4 ejsolutions, Jan 6, 2013
    Last edited: Jan 6, 2013
  5. filemaniac

    filemaniac Registered

    Joined:
    Jun 10, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
  6. WhiteDog

    WhiteDog Well-Known Member

    Joined:
    Feb 19, 2008
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Very weird!

    I was just about to try the suggestion from Jared mentioned in the other thread.
    When I logged on into cPanel, Munin was already installed! So somehow this must have been fixed by a yum or upcp update in the mean time.
     
Loading...

Share This Page