Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

munin issue with percona

Discussion in 'General Discussion' started by anand, Dec 15, 2013.

  1. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Hi,

    I installed percona as per How to replace MySQL with Percona in 11.36 | cPanel Blog, and after that tried to install Munin plugin. The plugin gave me the below error:

    Code:
    [20131215.035602]   Warning: Unable to set access on database tables in "munin_innodb" for MySQL InnoDB plugin usage.
    [20131215.035602]   
    [20131215.035602]   Encountered problem while setting MySQL InnoDB access. No further InnoDB access was performed.
    [20131215.035602]   Suggestion:
    [20131215.035602]      Verify input data, enable InnoDB, check config file '/etc/my.cnf', restart MySQL and then re-run /usr/local/cpanel/bin/build_munin_conf
    [20131215.035602]      or InnoDB chart may not function as expected.
    [20131215.035607]   Stopping Munin Node agents: cat: /var/run/munin/munin-node.pid: No such file or directory
    [20131215.035607]   kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
    [20131215.035607]   [FAILED]
    [20131215.035608]   Starting Munin Node: [  OK  ]
    
    Any ideas on how to resolve the above ?

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,895
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    While implementing Percona with cPanel/WHM is very straightforward, it's not officially supported. The error message indicates a lack of InnoDB support with your Percona installation. You may want to ensure InnoDB is not disabled in your /etc/my.cnf file. Note that you may want to switch back to MySQL if you are not comfortable making these types of custom changes.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Thanks Michael. The only issue is munin is not tracking mysql/percona in the graphs, rest everything seems to be working. And I did enable and check that INNODB is enabled.

    Will see if there is any other solution to get the graphing working :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,895
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    You can try manually running the Munin cron to update the graphs via:

    Code:
    su munin -c /usr/local/cpanel/3rdparty/perl/514/bin/munin-cron
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Thanks for the reply. I get the below error:

    This account is currently not available.

     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,895
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you logged via SSH as root? If so, it's likely Munin was not properly installed. Try reinstalling it via the "Manage Plugins" option in Web Host Manager.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Yes ofcourse I am logged in as root. Have already tried to reinstall, will check again and post results.


    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice