The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

munin sending a cron mail every 5 mins to /home/munin

Discussion in 'General Discussion' started by bidouilleur, Jul 14, 2015.

  1. bidouilleur

    bidouilleur Well-Known Member

    Joined:
    Apr 27, 2003
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    since this morning munin is acting up on my server that is rather new (less then a week old)
    It sends out a mail (saw it in logs) and when I go to /home/munin/mail..... (there is no user account munin btw)

    opening a mail in terminal shows me this

    perl: warning: Setting locale failed.

    perl: warning: Please check that your locale settings:

    LANGUAGE = (unset),

    LC_ALL = (unset),

    LC_CTYPE = "UTF-8",

    LANG = "en_US.UTF-8"

    are supported and installed on your system.

    perl: warning: Falling back to the standard locale ("C").



    I guess cron job is running but for some reason it is not happy and sending me a warning ... but can't seem to find how to solve it. seems server lacks some language but ...

    uninstalled munin and re installed it (sometimes that cleans out some mess) but nope, the moment I re install the mails start again so problem is deeper ..

    in /etc/sysconfig/i18n I have following

    Code:
    LANG="en_US.UTF-8"
    SYSFONT="latarcyrheb-sun16"
    LC_CTYPE="en_US.UTF-8"
    LC_ALL="en_US.UTF-8"
    LANGUAGE="en_US.UTF-8"
    anyone has a clue what's the problem and even better how to solve it before I start a ticket ...

    thanks for your kind help

    PS now another mail is coming to root with same complaint

    mail subject : Cron <root@first> /usr/local/bandmin/bandmin
    mail contant :
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you tried forcing a cPanel update?
     
  3. bidouilleur

    bidouilleur Well-Known Member

    Joined:
    Apr 27, 2003
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    nope, doing it now

    PS : finished and mails still coming in with the errors :(

    no one has an idea ?
    don't want to open a ticket for this if it is a minor issue but looking around I couldn't find any solution fixing it. Centos says cpanel changes so much their solutions won't do it ...
     
    #3 bidouilleur, Jul 14, 2015
    Last edited by a moderator: Jul 14, 2015
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,666
    Likes Received:
    646
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you notice the same errors when running those commands manually? If so, please let us know if the following command helps address the issue:

    Code:
    localedef --no-archive -i en_US -f UTF-8 en_US.UTF-8
    Thank you.
     
Loading...

Share This Page