Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MX records don't transfer with WHM API transfer

Discussion in 'General Discussion' started by rinkleton, Feb 2, 2017.

  1. rinkleton

    rinkleton Well-Known Member

    Joined:
    Jul 16, 2015
    Messages:
    61
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Cleveland
    cPanel Access Level:
    Root Administrator
    When I do a transfer with account password through WHM, everything works as expected, but when I used the API to do the same thing (not root transfer), the MX records don't transfer.

    create_remote_user_transfer_session
    unrestricted_restore = 1

    enqueue_transfer_item
    module = AccountRemoteUser
    xferpoint = 1

    Could this be remedied with the root transfer API?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,424
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I was unable to reproduce this issue on a test environment for a domain name with a custom MX record. Could you verify which versions of cPanel are installed on the source and destination servers? Also, what's configured under "Email Routing" when browsing the zone via "WHM >> Edit DNS Zone" for the domain name in question?

    Thank you.
     
Loading...

Share This Page