The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MX Records

Discussion in 'E-mail Discussions' started by Gizmokid2005, Jun 12, 2009.

  1. Gizmokid2005

    Gizmokid2005 Member

    Joined:
    Jun 12, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    192.168.10.100
    All,

    I'm here because this is where my host sent me. I need to know if there is a way to disable the mail handlers in cpanel. Right now as it's setup, I'd have to change the MX records for EACH domain that I have there to the correct MX records...I just want them to be ignored completely.

    Is it possible?? Or am I doomed to the long way?

    TIA

    -Gizmokid2005
     
  2. retali8

    retali8 Member
    PartnerNOC

    Joined:
    Oct 1, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Are you wanting to remove the MX record from all of your zone records or are you wanting to have it so your server doesn't handle mail for the domains at all? If so you could just remove the domains from the /etc/localdomains file but if you're having delivery issues with domains on your server that have their MX record pointing to a remote mail server you would remove the domain from /etc/localdomains and add it to /etc/remotedomains so that your server knows to lookup the MX record and deliver mail remotely for the domain.
     
  3. Gizmokid2005

    Gizmokid2005 Member

    Joined:
    Jun 12, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    192.168.10.100
    Right now, I'm on a shared hosting plan with no access to actual server files, just my own. I just want the hosting to ignore local mail handling and pass it to the NameServers, so it uses the mail records that are actually listed in the DNS. If you were to whois my domain it was showing the right records, but the hosting was overriding them and handling the mail locally.

    I checked in my hosting files, there is an /etc/ but no /etc/localdomains or /etc/remotedomains.
     
  4. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Since you are on shared hosting, you don't have access to those either!

    The /etc/localdomains and /etc/remotedomains files are in the main /ETC
    folder for the entire server and not on individual hosting accounts.

    This means you are right back to square #1 ...

    However, what you need to do is contact your hosting provider and ask
    them to move your domains from "localdomains" to "remotedomains" in
    the server and update your DNS MX zones (if still applicable).

    Once those two are done, local mail from within the server and your scripts
    will be delivered to wherever you have your mail handled offsite.
     
  5. Gizmokid2005

    Gizmokid2005 Member

    Joined:
    Jun 12, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    192.168.10.100
    That's what I figured. Thanks Spiral! I just wasn't sure if there was some option I could use to turn it off.
     
  6. Gizmokid2005

    Gizmokid2005 Member

    Joined:
    Jun 12, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    192.168.10.100
    Well, my host said they added the domains to the /etc/remotedomains and even with them there, if I remove the MX records from cpanel the mail uses the local server instead of the correct MX records. Is there something I'm missing?
     
  7. retali8

    retali8 Member
    PartnerNOC

    Joined:
    Oct 1, 2008
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ask them to make sure they removed it from /etc/localdomains and that it's only listed in /etc/remotedomains otherwise it will continue to try and deliver it locally. You may even have your host check the exim_mainlog to see why it's still attempting to deliver messages locally for your domain.
     
  8. Gizmokid2005

    Gizmokid2005 Member

    Joined:
    Jun 12, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    192.168.10.100
    Thanks retali8. I will have them check that. I wish I could do it myself.
     
Loading...

Share This Page