The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My clients cannot create emails

Discussion in 'E-mail Discussions' started by shanit, Jan 9, 2006.

  1. shanit

    shanit Well-Known Member

    Joined:
    Dec 18, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    In almost all of our cpanel hosting accounts email address's cannot be created I dont understand I need help with this, its not the quota now it says emails are created and they just dont show up now. I have made sure all of the accounts have like9999999 emails avalialbe

    I have an admin but this question just goes unanswered and I have no idea what to do atall

    its really this simple as to whats happening

    I log in to cpanel
    go to mail
    add/remove manage email accounts
    add account
    then I put in information i want for new email then i click submit
    then I the only option on the page is a go back link and a note saying accounts are created successfully
    so I went back to main email page when i clicked go back and no emails are there except the main one thats always created when an account is created.

    it just dont show them I'm sure they are probably created just like in limbo some where cuase it says its successfully created

    I cannot even get a response from my admin we pay monthly for to manage server, they arent even giving answers or fixing it!!!!

    So at this moment I'm Screwed!!!

    Please help someone


    Cpanel Logs

    root@server [~]# tail -f /usr/local/cpanel/logs/error_log
    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/
    1.1 session) at cpsrvd.pl line 1469.
    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/
    1.1 session) at cpsrvd.pl line 1469.
    Unable to create datastore file /home/badss/.cpanel-datastore/apache_LISTSUBDOMA
    INS_0: Bad file descriptor
    Unable to create datastore file /home/badss/.cpanel-datastore/apache_LISTMULTIPA
    RKED_0: Bad file descriptor
    Content-type: text/html

    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/
    1.1 session) at cpsrvd.pl line 1469.
    Content-type: text/html

    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/
    1.1 session) at cpsrvd.pl line 1469.

    I just tried to create emails on this account it pulled up the errors for to

    Thanks
    Shannon
     
    #1 shanit, Jan 9, 2006
    Last edited: Jan 9, 2006
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Login to server and execute the below script :-
    /scripts/upcp --force

    Give it a try.
     
  3. madhav

    madhav Member

    Joined:
    Jun 29, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    same problem

    Same problem here.
    upcp --force did not do the trick.
    Also in the General account information: section of the cpanel the email accounts is showing up as 0/20 when there are already 6 email accounts. :confused:

    Running out of ideas....

    Please need help..
     
  4. madhav

    madhav Member

    Joined:
    Jun 29, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    fixed it :)

    got the issue finally fixed. The reason why the email accounts were not showing up was because the permission for the folder
    /home/<username>/etc/<domainname>/
    was wrong. Somehow it was changed to root.root permission :confused: Also all the files in this folder passwd quota shadow passwd,v quota,v shadow,v were under the root permission.

    changing it back to the normal permissions of <user>.mail did the trick. :D
     
  5. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    I just delete the /home/USERNAME/.cpanel-datastore folder and this resolved the problem we saew on a couple of our servers, the CURRENT 6 and 9 releases seem to have been the cause CURRENT 10 seems to have fixed it
     
  6. ninad

    ninad Member

    Joined:
    Aug 15, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Cheers madhav. That fixed the issue :)
     
Loading...

Share This Page