The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MY.CNF Problem

Discussion in 'General Discussion' started by jackal, Oct 25, 2003.

  1. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    BEWARE!!!! MY.CNF Problem

    Today when we opened up one of Server WHM's panel we noticed this in the upper left hand corner.

    /usr/bin/install: cannot remove `/etc/my.cnf': Operation not permitted

    After doing some research we found out the reason for this. For sometime on this server we had a custom my.cnf file as follows. Read below it for more information.

    Now with this custom file we had my.cnf chattr'ed we have had this file like this for sometime without problems. Today when the error above top of this thread started showing up the only way to remove it was to unchattr the file. Then the error went away.

    But after this happened we started getting this error on all databases on the server.

    So the only way to fix this we found was this thread by nitromax

    http://forums.cpanel.net/showthread.php?s=&threadid=9257&highlight=my.cnf

    which we ran and we got our mysql back online. Only problem is now we can not get our custom file to work anymore. We can add it but if we do we must chattr it if not then it gets over written. So now we have only a default my.cnf loaded that is shown in the thread above.

    Like we mentioned earlier this just started today. We are running 8.5.4 e43

    Hoping this is a bug and someone can help, if not then someone may be able to help us get our custom settings back up and running and keeping it from being over written and at the same time not seeing the error in whm.

    Thanks


    Ticket Number: 27602
     
    #1 jackal, Oct 25, 2003
    Last edited: Oct 25, 2003
  2. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Seems this is the problem
    Fri Oct 24 20:00:21 EDT 2003
    8.5.4-EDGE_36
    ---------------------------------------------------------------
    turn on safe-show-database in my.cnf

    We running edge 35 until today


    Anyone that is running custom my.cnf file better not upgrade pass edge 35 if you do be ready for this same problem
     
  3. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    I just checked, and my settings have been overwritten, too. Let me know if you find something out.
     
  4. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    For now I went back to the latest release build until they get it fixed.

    My settings work with it.

    Pain in the butt had to convert all servers back
     
Loading...

Share This Page