The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My cPanel X fails to display files in public_html. Does any one know why?

Discussion in 'General Discussion' started by thk, Jun 15, 2011.

  1. thk

    thk Member

    Joined:
    Jun 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    When I open up the File Manager in my cPanel, it usually displays files in public_ftp or public_html. But lately it fails to do that. The space is blank.Why?

    This happened before. I was able to correct it by doing the following.
    Tools --> Internet Options-->Advanced-->Security-->enabled “Allow active content to run in files on My Computer*

    This time though it fails to correct the situation. Can anyone help?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,471
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Not sure why this would help at all with this issue. Can you tell me what browser you're using and what cPanel version? (version should be shown on left menu in cPanel)
     
  3. thk

    thk Member

    Joined:
    Jun 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    My browser is Internet Explorer 8. The cPanel version 11.30. Thank you for helping me.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you receive any specific error messages in the cPanel error log when attempting to display the files within public_html via File Manager?

    Code:
    /usr/local/cpanel/logs/error_log
    Also, do you notice any files/directories within the public_html directory that include special characters in their name?

    Thank you.
     
  5. thk

    thk Member

    Joined:
    Jun 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    No, No error messages. No, I have not noticed anything or anything different.

    It’s just that files do not show. The place is blank. I know files are there because when I use FireFox browser, I can see them. The reason I cannot use FireFox is that it gives an error message when I try to save a file after using HTML Editor.
    The error message with the FireFox is as follow:

    Error encoding as windows-12152:/usr/bin/iconvi illegal input sequence at position 3291.
    I don’t know what it means or how to correct it.

    Funny thing is that at Wbhosting pad, which is my host for web hosting, they cannot help me. They say it is the Browser problem. I’m sure it is, but I think they should be able to help. All they suggest is that I use FireFox. But I cannot use FireFox because of the error message.

    Thank you for your help. I really appreciate it because I feel I am stuck.
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You should be able to use Firefox, but you simply need to save files as utf-8. You appear to have your files encoded using a language other than utf-8 and the HTML editor is trying to convert it to the wrong type for set characters. We have an internal case about that issue.

    Also, have you simply tried using FTP instead? FTP is a lot easier to use to download and upload files. Filezilla is a free FTP client that you can find at this location:

    FileZilla - Client Download
     
  7. thk

    thk Member

    Joined:
    Jun 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    How do you save the files as utf-8?

    The public_ftp folder is also blank. I do not see any files in it.

    Could it be some screening or security block that prevents files from being displayed in the public_html folder?
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    In cPanel main area, please select the following option:

    reset all interface settings

    Then re-try File Manager to see if you are given a prompt in Firefox when opening a file for the encoding type and ensure to select utf-8 as the file type.

    Next, is the cPanel in English or some other language? I'm asking as we did have one case about Chinese language and the files not displaying. It is possible if you are using a language other than English that this might be applicable to why it isn't working.
     
  9. thk

    thk Member

    Joined:
    Jun 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I opened a file in utf-8. After editing, I saved in the file in utf-8.
    The web page showed up distorted in the FireFox browser.
    The same web page opened in IE8 also looked distorted and does not show the photo I posted.

    The cPanel I am using is in English. My web pages contain some Korean alphabets.

    It looks my hope lies in sticking to IE8. Using IE8, I did not have any problem with HTML Edit.
    What in IE8 that is different from FireFox that cause the problem of not displaying files in the public_html folder or in the public_ftp folder? Could it be filtering? Or some security blocker? I am just wondering.
     
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If your existing cPanel version is 11.30.0.32, then is there any way you can open up a ticket and provide a test file in that ticket for us to test this out? You can open up a ticket using the Bugs link at the top or by visiting http://go.cpanel.net/bugs

    Even without root access to the machine, if this is a bug and you have a file you can provide showing this occurring, we could see if this is an issue with that set language.

    If you aren't using 11.30.0.32, then it's possible that this is something already fixed in the 11.30.0.32 version.
     
  11. thk

    thk Member

    Joined:
    Jun 14, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Suddenly, the files in my public_html folder are displayed.
    At the same time the Security Warning Box reappeared. It says, “Do you want to view only the webpage content that was delivered securely? . . . . .” When I click on “NO” box, things work out. It may have something to do with Cookies. I don’t know.

    I still have problem that I didn’t have before. Using IE8, that is.

    When I edit and save a file as “windows-1252” using the HTML Editor of cPanel, I get the following Error message: “Error encoding as windows-1252:/usr/bin/iconvi illegal input sequence at position 3291.” This error didn’t occur before as you can see from the webpage at Column with Contents.

    When I edit and save a file as “utf-8” using HTML Editor of cPanel, the file can be saved successfully, but my Korean alphabets get broken. Is this due to a bug in cPanel? Or is it something else?

    I will appreciate your help.
     
  12. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please review my prior post. What cPanel version are you running? I am re-quoting exactly what I noted above:

     
Loading...

Share This Page