The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My domain is displaying default cPanel page

Discussion in 'General Discussion' started by SantiPixel, Mar 27, 2013.

  1. SantiPixel

    SantiPixel Registered

    Joined:
    Mar 18, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi. My domain is elhost.ws, the nameservers are ns1.elhost.ws and ns2.elhost.ws and my hostname is cloud.elhost.ws

    All are replying ok
    ns1.elhost.ws is pointing to 54.236.187.23
    ns2.elhost.ws is pointing to 54.236.187.24
    elhost.ws is pointing to 54.236.187.23
    cloud.elhost.ws is pointing to 54.236.187.23

    But when I enter to elhost.ws it shows me cPanel's default page.

    If I write: curl elhost.ws on my server I can see the web content. But If I do the same on another server I see the default page.

    It is my named.conf

    Code:
    include "/etc/rndc.key";
    
    controls {
            inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
    };
    
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    
    options {
            additional-from-cache no;
             allow-recursion { 127.0.0.1; 54.236.187.23;};
            notify no;
            version "none";
            query-source    port 53;
    //    listen-on { any; }; /*      updated by cPanel*/
    //      listen-on-v6 port 53 { ::1; };
            directory       "/var/named";
            dump-file       "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            memstatistics-file "/var/named/data/named_mem_stats.txt";
            allow-query     { any; };
            recursion yes;
    
            dnssec-enable yes;
            dnssec-validation yes;
            dnssec-lookaside auto;
    
            /* Path to ISC DLV key */
            bindkeys-file "/etc/named.iscdlv.key";
    
            managed-keys-directory "/var/named/dynamic";
    };
    
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
            };
    };
    
    zone "." IN {
            type hint;
            file "named.ca";
    };
    
    include "/etc/named.rfc1912.zones";
    include "/etc/named.root.key";
    
    
    zone "cloud.elhost.ws" {
            type master;
            file "/var/named/cloud.elhost.ws.db";
    };
    
    
    zone "ns1.elhost.ws" {
            type master;
            file "/var/named/ns1.elhost.ws.db";
    };
    
    
    zone "ns2.elhost.ws" {
            type master;
            file "/var/named/ns2.elhost.ws.db";
    };
    
    
    zone "elhost.ws" {
            type master;
            file "/var/named/elhost.ws.db";
    };
    What I could do?
    Thanks
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm not seeing the default cPanel page but a 403 Forbidden error at this point. Did you still need assistance with the issue?

    Typically, a Forbidden error could occur if you have indexing turned off and your site doesn't have an index.html, index.htm, index.php and such page. With indexing off and without a home page to display, the directory contents can't be displayed and so a forbidden error occurs. There are other reasons you might also get that due to incorrect file, folder, or ownership permissions, but the most typical cause is indexing being off and no home page.

    Thanks!
     
Loading...

Share This Page