WebTrooper

Member
Nov 7, 2004
22
0
151
When I go to Main >> Software >> Install an RPM it's empty, all my rpms are missing. Searching the forums I could only find one suggestion, to do a manual WHM update, but that didn't work


I'm guessing this part of the output has something to do with it...

-----------------------------------------------------------

Sync Source: http://httpupdate.cpanel.net/STABLE/scripts
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync.lock....Trying httpupdate.cpanel.net @ 69.72.164.151
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync.lock
...Done
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync.bz2....Trying httpupdate.cpanel.net @ 69.72.164.151
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync.bz2
...Done
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync....Trying httpupdate.cpanel.net @ 69.72.164.152
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync.bz2....Trying httpupdate.cpanel.net @ 69.72.164.151
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync.bz2
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync....Trying httpupdate.cpanel.net @ 69.72.164.151
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync.bz2....Trying httpupdate.cpanel.net @ 69.72.164.152
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync.bz2
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync....Trying httpupdate.cpanel.net @ 69.72.164.151
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync.bz2....Trying httpupdate.cpanel.net @ 69.72.164.151
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync.bz2
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync....Trying httpupdate.cpanel.net @ 69.72.164.152
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync.bz2....Trying httpupdate.cpanel.net @ 69.72.164.152
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync.bz2
...Done
Download Failed... trying again..
Unable to retrieve file
...Failed
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/scripts/.cpanelsync....Trying httpupdate.cpanel.net @ 69.72.164.152
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/STABLE/scripts/.cpanelsync
...Done
Tried to download the sync file 10 times and failed!
initfpsuexec: using apache 1.x support
Fetching http://httpupdate.cpanel.net/cpanelsync/STABLE/cpanel/version....100%......Done
Installed Version: 10.0.0-RELEASE_7
Newest Version: 9.9.9-STABLE_15

-----------------------------------------------------------


:confused: and my rpms are still nowhere to be found.
 

WebTrooper

Member
Nov 7, 2004
22
0
151
Thanks - I tried rpm --rebuilddb as root but it didn't work. The command prompt dissapeared for about 20 seconds, so I know it did something, but my rpms are still missing in WHM.

Any other ideas.
 

WebTrooper

Member
Nov 7, 2004
22
0
151
Maybe a dumb question, but I'm desperate here. I was just wondering, should I have tried doing 'rpm --rebuilddb' from a specific directory? I did it from root (/) directory.
 

WebTrooper

Member
Nov 7, 2004
22
0
151
Hey folks, I still havn't resolved this and It's driving me nuts. More ideas would be greatly appreciated. :)
 

haze

Well-Known Member
Dec 21, 2001
1,550
3
318
Ok, the 404 errors are caused by downgrading cpanel. Since your moving from Release to Stable, first rm -f /var/cpanel/version/9.9.9.* then try /scripts/upcp --force.

As for the RPM's. What OS is this you are running ? Is your package manager working correctly ? Which package manager are you using currently and do you have any others installed ?
 

WillyMore

Active Member
May 22, 2002
34
0
306
I have the same problem First it showed that I needed to register with rhnetwork. So I have done that now
 

theuruguayan

Active Member
PartnerNOC
Jul 6, 2003
37
0
156
well.. for the 404...

you need to go to /var/cpanel/version and delete all the files that are... Example: 9.*.*.*

then run ./updatenow

and then try ./upcp
 

WillyMore

Active Member
May 22, 2002
34
0
306
This system may not be updated until it is associated with a channel.

trouble with rhn license. like first stated. since I just signed up again I will give it a little time then pursue
 

WillyMore

Active Member
May 22, 2002
34
0
306
Fixed
I got in touch with the data center I lease from and they resolved the up2date registration problem