The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My server doesnt authentify users when sending email

Discussion in 'E-mail Discussions' started by Alejandro, Aug 30, 2004.

  1. Alejandro

    Alejandro Registered

    Joined:
    Aug 30, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    hi, this is my first post on this forum. I need help because my server doesnt authentify users when using smtp server. This has cost me a lot of crash beacause someone is sending a lot of spam. how someone could help me.
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    If you have root access to WHM under Service Configuration > Exim Configuration Editor - double check to see that "Verify the existence of email senders" is checked.
     
  3. Alejandro

    Alejandro Registered

    Joined:
    Aug 30, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Te option is on, but still dont work
     
  4. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Go into tweak settings and set the following to a very low number until you can figure it out.

    "The maximum each domain can send out per hour (0 is unlimited):"
     
  5. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    This is happening to one of my servers also, it will not let folks who authenticate via pop send email.
     
  6. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Ok, I tired several scripts stuff

    /scripts/updatenow
    /scripts/sysup
    /scripts/upcp

    And such...

    I opened a ticket, I can only say that this is only happening on one server so far.. need to check others..
     
  7. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    I noticed this:

    root@server01 [/etc]# ls -l relayhosts
    -rw-r--r-- 1 root root 0 Sep 1 09:41 relayhosts
    root@server01 [/etc]# ls -l relayhostsusers
    -rw-r--r-- 1 root root 0 Sep 1 09:41 relayhostsusers

    All other server, the file sizes are not zero. Premissions are identical also, so I am not sure this would be Exim. If anything, it is the pop server maybe...

    Wow, I hope Cpanel respondes quickly :)
     
  8. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    ran the scripts again, then exim4 and reinstalled exiscan and it is all working now... Not sure what it was there but maybe what I just tried works for you :)
     
  9. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    This answer I got from the Cpanel folsk was super high quality so I thought I would post it here:

    Is the antirelayd daemon running?

    If so and if they login to pop before they do SMTP yes it will work, apparently they're just doing SMTP, so they need SMTP authentication or antirelayd is not running.

    If there is a problem with a script then this should resolve it:

    Do these commands (as root via SSH):
    /scripts/mailperm
    /scripts/updatenow
    /scripts/exim4
    /scripts/fixeverything

    mv /usr/local/cpanel/cpanel /usr/local/cpanel/cpanel.old /scripts/updatenow
    /scripts/upcp --force
    service cpanel restart

    RPM USERS: Some users using rpm have reported the need for the following commands to be run before the ones above, please read your rpm manual (`man rpm`) and make sure you understand what you are doing as you are responsible for these actions:

    rm -f /var/lib/rpm/__*
    rpm --rebuilddb

    If you get "error: db4 error(16) from dbenv->remove: Device or resource busy" from the above command, RedHat says it is not a problem at all, its more like an FYI and not an error. Search google.com for that error for more details.

    NOTE: If you are trying to change trees (RELEASE,STABLE,etc) and it reverts to
    the tree you currently have regardless of what tree is selected at: WHM->Server Setup->Change Update Preferences then repeat the first 4 steps only do not use the --force flag with the upcp command.
     
Loading...

Share This Page