The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My server mailing use server email adress instead of my domaine email adress

Discussion in 'E-mail Discussions' started by dolomats, Feb 22, 2015.

  1. dolomats

    dolomats Active Member

    Joined:
    Dec 14, 2014
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Website Owner
    Hello

    Well I hope i will be enough clear so i have a mailing system on my server that I use for sending newsletters

    Last time i worked on my domain email authentification (SPIF - DKIM - SpamAssasin - Blacklist) and i got 10/10 trusted email.

    The problem is when i send my newsletter it use the server default email and not my domain default email
    and it goes on the spam.

    Here is the headers of a mail sent with my email domaine and another sent with the server email domaine.

    My domain email sent from Roundcube to show that my domain is well authenticated

    Code:
    Delivered-To: test@gmail.com
    Received: by 10.27.175.159 with SMTP id z31csp874422wlh;
            Sun, 22 Feb 2015 12:45:47 -0800 (PST)
    X-Received: by 10.194.77.230 with SMTP id v6mr16194311wjw.25.1424637947003;
            Sun, 22 Feb 2015 12:45:47 -0800 (PST)
    Return-Path: <admin@mydomaine.com>
    Received: from server.domaine.net (server.domaine.net. [22.222.222.2])
            by mx.google.com with ESMTPS id jo8si58171204wjc.160.2015.02.22.12.45.45
            (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
            Sun, 22 Feb 2015 12:45:46 -0800 (PST)
    Received-SPF: pass (google.com: domain of admin@mydomain.com designates 22.222.222.2 as permitted sender) client-ip=22.222.222.2;
    Authentication-Results: mx.google.com;
           spf=pass (google.com: domain of admin@mydomain.com designates 22.222.220.2 as permitted sender) smtp.mail=admin@mydomain.com;
           dkim=pass header.i=@mydomain.com
    DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=mydomain.com; s=default;
    	h=Message-ID:Subject:To:From:Date:Content-Transfer-Encoding:Content-Type:MIME-Version; bh=KKqthBPSbx3yzBwMcDw0cCe226lEUHo62V9rBEtap1s=;
    	b=gXtRn9lBCkiz1ur0iFDZTezwCDmautpYopSmtJ4gX/9XI/3YDPtu4nYgkrn9g0ZGodgPHaQzoh9LPkUsASs1HKPY8eGcsmra6QIfkasKkfVp+TDJpToQNkoYx6Ab/eBtahjAnyO1vkinZjrnJVThk6+gtLiM5R/7HEfozwXZgvI=;
    Received: from localhost ([::1]:54385 helo=server.domaine.net)
    	by server.domaine.net with esmtpa (Exim 4.84)
    	(envelope-from <admin@mydomain.com>)
    	id 1YPdPP-0003jj-EF; Sun, 22 Feb 2015 20:45:47 +0000
    MIME-Version: 1.0
    Content-Type: text/plain; charset=US-ASCII;
     format=flowed
    Content-Transfer-Encoding: 7bit
    Date: Sun, 22 Feb 2015 21:45:46 +0100
    From: admin@mydomain.com
    To: test@gmail.com, test@gmail.com
    Subject: test
    Message-ID: <38852538689c7e24e0a41b70d0015fb0@mydomain.com>
    X-Sender: admin@mydomain.com
    User-Agent: Roundcube Webmail/1.0.5
    X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
    X-AntiAbuse: Primary Hostname - server.domain.net
    X-AntiAbuse: Original Domain - gmail.com
    X-AntiAbuse: Originator/Caller UID/GID - [47 12] / [47 12]
    X-AntiAbuse: Sender Address Domain - mydomain.com
    X-Get-Message-Sender-Via: server.domain.net: authenticated_id: admin@mydomain.com
    
    TES TEST TES
    The default Server email that is used by the newsletter
    Code:
    Delivered-To: test@gmail.com
    Received: by 10.27.175.159 with SMTP id z31csp875361wlh;
            Sun, 22 Feb 2015 12:48:53 -0800 (PST)
    X-Received: by 10.194.6.70 with SMTP id y6mr15551312wjy.97.1424638133835;
            Sun, 22 Feb 2015 12:48:53 -0800 (PST)
    Return-Path: <cpanel_user@server.domain.net>
    Received: from server.domain.net (server.domain.net. [22.222.222.2])
            by mx.google.com with ESMTPS id i10si14187197wif.64.2015.02.22.12.48.53
            for <test@gmail.com>
            (version=TLSv1.2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
            Sun, 22 Feb 2015 12:48:53 -0800 (PST)
    Received-SPF: none (google.com: cpanel_user@server.domain.net does not designate permitted sender hosts) client-ip=22.222.222.2;
    Authentication-Results: mx.google.com;
           spf=none (google.com: cpanel_user@server.domain.net does not designate permitted sender hosts) smtp.mail=cpanel_user@server.domain.net
    Received: from cpanel_user by server.domain.net with local (Exim 4.84)
    	(envelope-from <cpanel_user@server.domain.net>)
    	id 1YPdSR-0003nw-8n
    	for test@gmail.com; Sun, 22 Feb 2015 20:48:55 +0000
    To: test@gmail.com
    Subject: TEST
    X-PHP-Script: mydomain.com/admin/admin.php for 105.154.41.156, 22.222.222.2
    Date: Sun, 22 Feb 2015 20:48:55 +0000
    From: "Mywebsite" <noreply@test-mail.com>
    Message-ID: <e3e830ac5dac5a7e91fa313fb439ba6f@mydomain.com>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
    Reply-To: "admin" <admin@mydomain.com>
    X-Mailer: PHP5.5.21
    MIME-Version: 1.0
    MIME-Version: 1.0
    Content-Type: text/html; charset=UTF-8
    Content-Transfer-Encoding: 8bit
    X-AntiAbuse: This header was added to track abuse, please include it with any abuse report
    X-AntiAbuse: Primary Hostname - server.domain.net
    X-AntiAbuse: Original Domain - gmail.com
    X-AntiAbuse: Originator/Caller UID/GID - [504 504] / [47 12]
    X-AntiAbuse: Sender Address Domain - server.domain.net
    X-Get-Message-Sender-Via: server.domain.net: authenticated_id: cpanel_user/only user confirmed/virtual account not confirmed
    
    TEST TEST
    
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,145
    Likes Received:
    34
    Trophy Points:
    48
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hello,

    I can see you are using php mail function on your domain to send all mails and due to that you are getting this issues, I will suggest you please enable SMTP mail authentication in your newsletter setting and check this.
     
  3. dolomats

    dolomats Active Member

    Joined:
    Dec 14, 2014
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Website Owner
    Thanks for Answer.

    This is a wordpress plugin cant really edit it and dont have the authentication option on it.

    There is no other modification that i can do in the server to make him use another dafault email ?

    Thank you.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The default behavior when sending email through PHP is to use the cPanel username and hostname of the server to construct the envelope-sender address. If you can configure the mailer to use SMTP and authenticate with SMTP AUTH, this will set the correct "Return-Path" in the headers. You may need to consult with the developer of that plugin to see if it's possible to use SMTP authentication.

    Thank you.
     
  5. dolomats

    dolomats Active Member

    Joined:
    Dec 14, 2014
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Website Owner
    Ok i got it Thank s guy's
     
Loading...

Share This Page