my user have problem with sending activate emails from Vbulletin and php nuke !!!

mahdiparak

Registered
Mar 7, 2006
1
0
151
hi ,

some of my user , have problem by sending activate email , from their forums.
(Vbulletin and phpnuke)

this issue happen since i checked (Prevent the user "nobody" from sending out mail to remote addresses) box in Tweak setting , for preventing Spammers.

please let me know , how can i fix this issue ?

Suexec was enabled in my server , but i dont enable PhpSuexec in apache build .
 

Infopro

Well-Known Member
May 20, 2003
17,090
517
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
hi ,

some of my user , have problem by sending activate email , from their forums.
(Vbulletin and phpnuke)

this issue happen since i checked (Prevent the user "nobody" from sending out mail to remote addresses) box in Tweak setting , for preventing Spammers.

please let me know , how can i fix this issue ?

Suexec was enabled in my server , but i dont enable PhpSuexec in apache build .


Uncheck it.
 

jandafields

Well-Known Member
May 6, 2004
435
6
168
USA
cPanel Access Level
Root Administrator
Yep, since you don't run suphp or suexecphp, all your scripts (including vb and phpnuke) will run as nobody. If you prevent "nobody" from sending mail, there is your problem.
 

cjmwebdesigns

Well-Known Member
Dec 20, 2003
72
0
156
New Jersey
cPanel Access Level
Root Administrator
Twitter
Yep, since you don't run suphp or suexecphp, all your scripts (including vb and phpnuke) will run as nobody. If you prevent "nobody" from sending mail, there is your problem.
OK, I have been allowing users to send as nobody with bulletin boards and such for quite some time, but as the nature of the beast I am tired of receiving all of their unable to send messages. How does one go about installing or running the above programs? Are they just in WHM? I see something to check them, but, I am not sure if I have done it right in the past as I generally have an issue as soon as I prevent user nobody.

Thanks,
 

cjmwebdesigns

Well-Known Member
Dec 20, 2003
72
0
156
New Jersey
cPanel Access Level
Root Administrator
Twitter
In WHM, choose recompile apache, and it is an option there.
OK, will try to find this option. As far as turning this on, then how does the mail by the forum user get sent? Instead of [email protected] how does it get viewed by the reciever of the e-mail?
 

cjmwebdesigns

Well-Known Member
Dec 20, 2003
72
0
156
New Jersey
cPanel Access Level
Root Administrator
Twitter
OK. I found an option for in suexecphp under the tab for Service Configuration and the option is presently enabled.

The e-mails still go out as nobody.

I cannot find the Recompile Apache option.

I am in root access, as I know this will be a question.

Thanks,
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
OK. I found an option for in suexecphp under the tab for Service Configuration and the option is presently enabled.

The e-mails still go out as nobody.

I cannot find the Recompile Apache option.

I am in root access, as I know this will be a question.

Thanks,
To Recompile Apache, in WHM go to Software -> Apache Update
 

cjmwebdesigns

Well-Known Member
Dec 20, 2003
72
0
156
New Jersey
cPanel Access Level
Root Administrator
Twitter
Yep, since you don't run suphp or suexecphp, all your scripts (including vb and phpnuke) will run as nobody. If you prevent "nobody" from sending mail, there is your problem.
You learn something new every day, no wonder why setting this option in WHM had not been doing anything, there were more setting to set.

We are recompiling now. thanks for the help.
 

cjmwebdesigns

Well-Known Member
Dec 20, 2003
72
0
156
New Jersey
cPanel Access Level
Root Administrator
Twitter
I have completed this with success, however, would this create any new issues? I have clients running ZenCart and now I am seeing messages that their configure.php is set with the wrong permissions.

I am also have issues changing those permissions from FTP or cPanel's file manager. I had to go in and change them via root.
 

Frimon86

BANNED
Jun 4, 2007
31
0
156
hi ,

some of my user , have problem by sending activate email , from their forums.
(Vbulletin and phpnuke)

this issue happen since i checked (Prevent the user "nobody" from sending out mail to remote addresses) box in Tweak setting , for preventing Spammers.

please let me know , how can i fix this issue ?

Suexec was enabled in my server , but i dont enable PhpSuexec in apache build .
I had this issue before and it was something to do with the mail server, have you checked your mail server?