MySQL 10.3.23 [Warning] Could not increase number of max_open_files

Operating System & Version
CENTOS 7
cPanel & WHM Version
86.0.20

[email protected]

Well-Known Member
Aug 3, 2016
59
5
8
Everywhere
cPanel Access Level
Root Administrator
Hello,

I have a warning to my database that says:
Code:
[Warning] Could not increase number of max_open_files to more than 10000 (request: 37190)
When I go and change manually from my.cnf the limit and make restart of the Mysql the error it's the same.
Code:
open_files_limit=80000
I have WHM 86.0.20 {With that version the CPANEL-32712 it's fixed at least}.

Any advice? What I must do to prevent that kind of warning and the database run smooth?

Thank you in advance!
 

vacancy

Well-Known Member
Sep 20, 2012
468
163
93
Turkey
cPanel Access Level
Root Administrator
Setting, WHM > Tweak settings > Allow cPanel & WHM to determine the best value for your MySQL open_files_limit configuration > Off

After mysql/mariadb restart.
 

DigiTimber

Registered
Jul 1, 2019
1
0
1
Earth
cPanel Access Level
Root Administrator
I had the same issue after restarting the db service in 86.0.20, check /etc/systemd/system/mariadb.service.d/migrated-from-my.cnf-settings.conf.
Don't forget a 'systemctl --system daemon-reload' if you make any changes, then restart the service.