avio

Well-Known Member
Oct 6, 2003
95
0
156
When will cpanel update to 4.1.18? Which is the latest version.

Any ideas?
 

avio

Well-Known Member
Oct 6, 2003
95
0
156
What about MySQL5? When will that be coming along? Is it not compatible yet or something?

According to mysql website:

Current Release (Recommended):
MySQL 5.0 -- Generally Available (GA) release for production use

Older Releases:
MySQL 4.1 -- Previous GA release

We should be using 5.0 that means not 4.1, because its old.
 

AndyReed

Well-Known Member
PartnerNOC
May 29, 2004
2,221
4
193
Minneapolis, MN
avio said:
When will cpanel update to 4.1.18? Which is the latest version.

Any ideas?
How about sending the enquiry to the cPanel teams at: [email protected]

Please, disregard this note. Read cpaneljosh's note and follow his instructions. Thank you!
 
Last edited:

avio

Well-Known Member
Oct 6, 2003
95
0
156
Well I hope there is an update soon, already submitted to enhancements.
 

matriarchy

Member
Apr 11, 2002
6
0
301
Philadelphia USA
There is an open bugzilla report, but it only has five votes! It's been open for a long time.

Meanwhile, UTF-8 is not fully supported until 4.1.16. Unicode!

Someone needs to get busy on this.
 

umutbesler

Active Member
Jul 23, 2005
34
0
156
Blue|Fusion said:
You can always upgrade manually like me. Been running MySQL 4.1.18 since it was released (4.1.16 prior).
We can install all programs manually, but then why are we paying to cPanel?

I don't know why those updates are avaliable very very late.
This is not hard to implement the new version i think. May be 5.0x is hard to implement, it is ok but 4.1.14 -> 4.1.18 is not.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
umutbesler said:
We can install all programs manually, but then why are we paying to cPanel?

I don't know why those updates are avaliable very very late.
This is not hard to implement the new version i think. May be 5.0x is hard to implement, it is ok but 4.1.14 -> 4.1.18 is not.

There are known issues with mysql > 4.1.14 and older operating systems. We are working on a long term solution to the problem.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
webignition said:
What are the chances introducing the option of mysql > 4.1.14 only for those operating systems with which you know it does work, or more likely denying it for operating systems with which you know it does not work?

That would seem a fair compromise.
I wouldn't worry about it as we have a working solution that is just about to go though QA.
 

webignition

Well-Known Member
Jan 22, 2005
1,880
0
166
cpanelnick said:
There are known issues with mysql > 4.1.14 and older operating systems. We are working on a long term solution to the problem.
What are the chances introducing the option of mysql > 4.1.14 only for those operating systems with which you know it does work, or more likely denying it for operating systems with which you know it does not work?

That would seem a fair compromise.
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,488
35
158
cPanel Access Level
DataCenter Provider
webignition said:
What are the chances introducing the option of mysql > 4.1.14 only for those operating systems with which you know it does work, or more likely denying it for operating systems with which you know it does not work?

That would seem a fair compromise.

Mysql 4.1.18 or 5.0.18 (as selected in WHM) will be installed with tonight's BETA build.
 

Solokron

Well-Known Member
Aug 8, 2003
850
1
168
Seattle
cPanel Access Level
DataCenter Provider
It installed 4.1.14 not 4.1.18.

cpanelnick said:
Mysql 4.1.18 or 5.0.18 (as selected in WHM) will be installed with tonight's BETA build.
 

Solokron

Well-Known Member
Aug 8, 2003
850
1
168
Seattle
cPanel Access Level
DataCenter Provider
ok, I am running bleeding edge which must not count as beta then. After that upgrade with 4.1.14 I have clients receiving internal server errors all over the place.

*Recompiling Apache and PHP after the update resolved the issue.
 
Last edited:

pross

Well-Known Member
Mar 14, 2005
75
0
156
ive just done upcp in EDGE and finally got .18 at last! so far so good