The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL 4.1.19 issues

Discussion in 'General Discussion' started by netlook, Jun 2, 2006.

  1. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    After few days of running MySQL 4.1.19 (latest from RELEASE), we have to tell you that it is so buggy that we never expected.

    Almost every hour we have few queries in state Locked or Sleeping for over 30 minutes :mad:

    Is anybody have simillar problems? Is there anything extra we should put in config my.cnf to be sure that long time sleeping queries or locked queries for more than 3-4 minutes will be killed automatically?

    Any help would be apreciated.

    Thanks
     
  2. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    We upgraded all our server to 4.1.19 just 24hrs ago on RHEL3 and FreeBSD servers. Neither of them have shown signs of a problem. Maybe its OS specific i dont know but Im happy to report no issues with them.

    root 26470 0.0 0.0 2168 916 ? S Jun01 0:00 /bin/sh /usr/bin/mysqld_safe --datadir=/var/lib/mysql --pid-f
    mysql 26499 0.0 3.6 226452 37116 ? SN Jun01 0:44 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=
    m
     
  3. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    Don't you see in mysqladmin processlist any log-time-sleeping connections to mysql?
     
  4. rs-freddo

    rs-freddo Well-Known Member

    Joined:
    May 13, 2003
    Messages:
    832
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    I have never had mysql crash with "out of memory" errors, until I upgraded to 4.1. It's done that a couple of times now...
     
  5. AnthonyCaesar

    AnthonyCaesar Active Member

    Joined:
    Feb 21, 2005
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    I installed it and everything is working fine for all my clients with the exception of one. Who is now getting 500 Internal Server Errors with there phpBB forum. Does anyone think this is related.
     
Loading...

Share This Page