The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL 4.1 question

Discussion in 'General Discussion' started by drsprite, Feb 2, 2006.

  1. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    I upgraded to MySQL 4.1, but forgot to check the checkbox that reads "Use old style (4.0) passwords with MySQL 4.1..."

    I want to have that check box checked. Do I need to downgrade back to 4.0, then re-upgrade to 4.1?
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Can you not just check that option in Tweak Settings and then save the changes?
     
  3. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    I thought I could, so I recompiled mysql like the instructions say, but when I go back in the box is still unchecked... so I don't know if it took the change or not.
     
  4. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Any thoughts as to if I need to downgrade and upgrade again?
     
  5. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    open /etc/my.cnf using ssh and your favorite editor and add this to it

    old-passwords

    save the file and restart mysql

    should look similar to this when completed
     
  6. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    Mine has this. I added the old-passwords to the bottom of it.

    Should I have the other stuff added to it as well?



    [mysqld]
    set-variable = max_connections=500
    safe-show-database
     
  7. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    that should be all you need
     
  8. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    6
    thanks for the help!
     
Loading...

Share This Page