SOLVED MySQL 5.6 not available?

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello @omerjix,

MySQL version 5.7 is installed by default on new cPanel installations, and downgrading to an older version isn't supported. The only way to install MySQL version 5.6 is to create the /root/cpanel_profile/cpanel.config file prior to starting the cPanel installation and ensure it contains the following line:

Code:
mysql-version=5.6
This will ensure MySQL version 5.6 is installed at the same time that cPanel is installed. Documentation on this topic is available at:

Installation Guide - Customize Your Installation - Version 70 Documentation - cPanel Documentation

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello @omerjix,

you mean by the installation process: the first installation when connecting from port 2087?
You'd have to configure it before installing cPanel (e.g. before starting the process documented here). The installation process is already complete if WHM is accessible over port 2087.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
How do I access this file and change it? Because I do not see the cPanel files and they are not open source. How can I do this intervention?
You would create and edit this file via the command line before starting the installation. EX:

Code:
vi  /root/cpanel_profile/cpanel.config
Keep in mind you can't make this change if cPanel is already installed. It's only a file that's utilized prior to installing cPanel.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
How else can I use MySQL version 5.6? For any website
Hello @omerjix,

It's not possible to install or use MySQL version 5.6 if MySQL version 5.7 is already installed on the system. You'd have to backup your accounts to a remote location, reinstall cPanel with MySQL version 5.6 using the instructions above, and then restore the accounts.

Thank you.
 

omerjix

Member
Aug 28, 2018
6
1
3
turkey
cPanel Access Level
DataCenter Provider
Hello again,
Thank you very very much.

I did it the way you wanted it and I got the solution. I explain the solution below.
Maybe they are the ones who have the same problem, find it as a solution.

mkdir -p /root/cpanel_profile/

vi /root/cpanel_profile/cpanel.config
we are writing: mysql-version=5.6
Key-> esc :wq

that's it
Thank you Bro.
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
I started having the same problem again. But 5.6 I can't load Mysql database. How should I proceed?
Hello :)

It's possible this relates to internal case CPANEL-28797 where MySQL 5.6 dependencies are not met during the initial installation. This is fixed in cPanel & WHM version 84, with a backport planned in the next cPanel & WHM version 82 build.

Can you confirm the issue you are facing is the inability to define MySQL 5.6 as the MySQL version during installation? If so, can you share the output from /var/log/cpanel-install.log on a server where this failed?

tail -100 /var/log/cpanel-install.log

Thank you.
 

biswajitjsp

Registered
May 19, 2020
1
0
1
India
cPanel Access Level
Root Administrator
Hi there, I need to install mysqal version 5.6 - 86_64 version after installing the latest version of centos on a new server. Oh how do I install. Will you give a step by step command?