MySQL 5.6 to 5.7 upgrade seemless?

andrew.n

Well-Known Member
Jun 9, 2020
330
72
28
EU
cPanel Access Level
Root Administrator
Yes! If you go to MySQL Upgrade on the left and choose the new version then click on Next you will see all the warnings you should consider before upgrading it :)
 

cPJeremy

Technical Analyst
Staff member
Feb 13, 2019
55
2
83
Houston TX
cPanel Access Level
Root Administrator
Hello @Scott Galambos !

Firstly, I did want to mention that andrew.n is correct. When you use WHM and select the new version you would like to install, there are some warnings that you will have to manually agree to before upgrading. This will give you an opportunity to ensure your sites may be compatible.

However, one thing I did want to mention is that one issue that users can encounter when upgrading from MySQL 5.6 to 5.7 are issues with MySQL's "Strict Mode." There are some changes that are enabled by default in MySQL 5.7. Specifically, the SQL mode "Strict Trans Tables" being enabled. Depending on how some sites were developed to use MySQL, some sites may not work properly if "Strict Trans Tables" is enabled. I wanted to include another forums thread for reference. Even though this thread below is for a user going from MySQL 5.5 to 5.7, the information in the thread is still helpful.

MySQL 5.5 to 5.7

I would first determine if there are some sites that might be affected by this specifically. As it is not possible to downgrade a MySQL version. However, if you upgrade to MySQL 5.7 and some sites are not working normally you can disable the MySQL mode "Strict Trans Tables" using the information in the post above. Also, you can open a support ticket using the link in my signature if you require further assistance as we can conduct the upgrade for you.

I hope this helps!