Mysql 5.7 as recommended in v.88 instead of MariaDB ?

bejbi

Well-Known Member
PartnerNOC
Jan 20, 2006
153
27
178
Poland
cPanel Access Level
DataCenter Provider
In release notes of v.88 it is writen: "New installations of cPanel & WHM version 88 will continue to use MySQL 5.7 by default. "

Does it mean that "recomended" version from cPanel v.88 will be MySQL instead of MariaDB 10.3.x as it was in cPanel v.86 ?

Or is it only information about MySQL 5.7 as a default before MySQL 8.0 (MySQL 8.0 will be not installed by default) ?
 

jacksony

Well-Known Member
PartnerNOC
Nov 30, 2005
77
1
158
Hi!

We also got concern for these since we are implementing the standard across all our cPanel shared servers, so it is crucial for us going ahead right.

We are still using MySQL 5.7 across all now. Going ahead in the next month or so, we will need to decide to go to MariaDB or MySQL 8.0, after having all cPanel updated to v88.

What will be the recommendation for us to go ahead? To go to MySQL 8.0 or MariaDB?
 

bejbi

Well-Known Member
PartnerNOC
Jan 20, 2006
153
27
178
Poland
cPanel Access Level
DataCenter Provider
the only problem with mariaDB 10.3 is that Magento can not run under it (it supports only mysql 5.7 or mariaDB up to 10.2) - but it is Magento problem of course.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
the only problem with mariaDB 10.3 is that Magento can not run under it (it supports only mysql 5.7 or mariaDB up to 10.2) - but it is Magento problem of course.
I assume that will eventually change as well once they're able to update.