The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL Access Errors, Tried Everything, Need Solution!

Discussion in 'General Discussion' started by Madacc, Nov 3, 2003.

  1. Madacc

    Madacc Registered

    Joined:
    Sep 15, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Alright, we just upgraded our server and we used the account transfer feature to transfer our accounts to the new server. Everything seemed to be going very smooth, until we ran into a plethra of MySQL problems. First of all, the databases work, but they are not displaying in cPanel. Also, if you try to use phpmyadmin it gives a WRONG USERNAME/PASSWORD error. If I try to do anything with the root account, I get

    ERROR 1045: Access denied for user: 'root@localhost' (Using password: YES)

    I've read every thread on this forum that pertains to this problem. The suggestions are check your /root/.my.cnf for the root password (it's there), reset your password (tried over and over, using every method mentioned), make sure your password has no special characters (mine doesn't). I have tried everything, and no matter what I still get the 1045 error and the databases are still hidden and unaccessible in cPanel. The databases were all switched over correctly, because they show up in /var/lib/mysql/ so I'm completely out of ideas. Please give me NEW suggestions, because all of the previous suggestions are not working.
     
  2. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
    Have you found an answer? I would like to know. thanks
     
  3. essene

    essene Member

    Joined:
    Apr 13, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Calgary, Alberta
    Im receiving the same exact errors as well.

    However, we did not do a transfer..Actually we havent done anything.

    All existing db driven applications are working, however when you click on 'Mysql databases" in cpanel, nothing shows up.

    When you try to create a user and password, nothing shows up,

    When you try to create a db, it tells you that youre successful, but nothing shows up.

    I click on phpmyadmin and it tells me i have an incorrect username and password.

    Im stuck and so are the 130 accounts on my server
     
  4. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
    I had a problem with changing the root MySQL password.. tried restarting MySQL several times, tried different methods of changing MySQL root password.. Eventually, rebooted the server and was then able to change the MySQL root password. So, I would recommend a reboot as a last resort, and open a trouble ticket with Cpanel.
     
  5. furquan

    furquan Well-Known Member

    Joined:
    Jul 27, 2002
    Messages:
    425
    Likes Received:
    0
    Trophy Points:
    16
  6. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    I'm experiencing the same sorts of things... last night, all was well, today, phpMyAdmin refuses accept the username:password being passed by cpanel when a user is logged in.

    I've searched through the forums quite a bit, have tried the fix mentioned here as well as others, all to no avail.

    I'm using;

    WHM 8.5.4 cPanel 8.5.4-R72
    RedHat 8.0 - WHM X v2.1.1
    mysql (4.0.15-standard)
    phpMyAdmin 2.5.2

    I haven't installed anything or changed anything that I am aware of, from what was working fine for the last 2 weeks I've had this box.

    I don't seem I'm the only one encountering this, though some of the posts I've read are quite old and apply to earlier versions of cpanel.

    Is there a definitive fix?

    Thanks,
    verdon
     
  7. andyf

    andyf Well-Known Member

    Joined:
    Jan 7, 2002
    Messages:
    246
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    check your root password is correct in /root/.my.conf
     
  8. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    yes it is, at least it is the password I have set using whm to set my root mySql password. I'm assuming that's what should be there?
     
  9. robertgarrigos

    Joined:
    Sep 1, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    this must be a bug with whm. I just changed root password thru whm and got an error message when the system tries to change mysql root pass. it says root user doesn't exist.

    i'll check those posts about the right directory to find the root pass. In any case, if that's the problem, cpanel did something wrong (during an upgrade maybe?) because I always do everything thru whm.

    RG
     
  10. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    cPanel bug seems likely, as when I checked this morning (after auto-updates running last night) the problem has gone away?

    thanks all,
     
  11. robertgarrigos

    Joined:
    Sep 1, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    nop. just updated cpanel and got the same error when changing root password:

    Changing password for root
    Password for root has been changed
    Updating mysql database access...
    Invalid Username.
    Done

    RG
     
  12. shimmy

    shimmy Active Member

    Joined:
    Nov 13, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    was this ever solved? I have the same problem now.
     
  13. sloop

    sloop Well-Known Member
    PartnerNOC

    Joined:
    May 4, 2003
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    north carolina
  14. shimmy

    shimmy Active Member

    Joined:
    Nov 13, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Hi, yes i tried a reboot and still can't change the password
     
  15. moogle

    moogle Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    I did the manual password change suggested above and it fixed my entire problem. Have you tried that?
     
  16. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    much as I hate mysteries... I've found it comes and goes with n o pattern I can detect. I just ignore it now and it resolves itself after some unknown event or amount of time..
     
  17. hostit1

    hostit1 Well-Known Member

    Joined:
    Jul 24, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    0
    Try this. I had the same problem and nothing worked.

    Make sure root pass is in /root/.my.cnf

    This is usually the first root pass the box was given once cpanel is installed.

    If it still does not work, you will need to reset the mysqld root pass. First, stop the mysqld:
    /etc/rc.d/init.d/mysql stop

    Then stop chkservd to keep it from interfering with mysqld while you work on it with:
    /etc/rc.d/init.d/chkservd stop

    Start up mysqld , but, without the grant tables:
    mysqld --skip-grant-tables -u mysql
    Then change the pass.:
    UPDATE user SET Password=PASSWORD('new_password') WHERE user='root'; FLUSH PRIVILEGES;

    Now you just:
    killall -9 mysqld

    and start it up normally with it's safe_mysqld script..

    This info was found from:
    http://faq.cpanel.net/show.cgi?qa=104700616405907
     
Loading...

Share This Page