The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL and BIND problem

Discussion in 'Bind / DNS / Nameserver Issues' started by luci2200, Mar 10, 2008.

  1. luci2200

    luci2200 Member

    Joined:
    Mar 5, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bucharest, Romania
    Hello, I'm trying to start MySQL server on my cPanle, but I get the following error:
    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)' Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists! mysql has failed, please contact the sysadmin (result was "Warning, no valid mysql.sock file found.mysql has failed"). I use CentOS 5.0 x86_64 cPanel. The server version was downloaded from cPanel web site.

    And my second problem is BIND. I am trying to start BIND from VHM and I get the following error:
    named has failed, please contact the sysadmin (result was "named is not running"). Mar 10 10:05:40 sun named: none:0: open: /etc/named.conf: file not found. The file named.conf is on the server but it seems is it can't be read. Regarding mysql error no mysql.sock file is on the server.

    I use WHM 11.15.0 cPanel 11.18.2-R21613
    CENTOS Enterprise 5 x86_64 on standard - WHM X v3.1.0 the demo version. Can be the demo version the problem?

    Lucian
     
  2. cPanelJesse

    cPanelJesse Technical Analyst Manager
    Staff Member

    Joined:
    Sep 19, 2007
    Messages:
    51
    Likes Received:
    6
    Trophy Points:
    8
    Location:
    Houston
    cPanel Access Level:
    Root Administrator
    The MySQL issue can be a number of causes, such as a previous version being stuck in the rpm's. (You can check by running rpm -qa |grep MySQL) Have you recently upgraded MySQL? Running /scripts/mysqlup --force can usually resolve your issues.

    It seems named is not able to read /etc/named.conf so it may have the wrong permissions or it is chattr +i

    If you provide the output of the permissions on named.conf ( ls -al |grep /etc/named.conf ) it could be better determined.
     
  3. luci2200

    luci2200 Member

    Joined:
    Mar 5, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Bucharest, Romania
    Hello, the problem seems to be solved! I use DNS - BIND with out chroot and it is running. With MySQL I make a Server software update from WHM and now MySQL is srunning. I have a problem configuring apace with php right now because if I try to acces a page ith phpinfo() script I get the following error:
    Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

    Fatal error: Unknown: Failed opening required '/home/icsnet/public_html/test.php' (include_path='.:/usr/lib64/php:/usr/lib/php:/usr/local/lib/php') in Unknown on line 0. Thank you for your reply!

    Lucian
     
Loading...

Share This Page