The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mysql api

Discussion in 'General Discussion' started by Secret Agent, Jun 14, 2005.

  1. Secret Agent

    Secret Agent Guest

    Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/velocity/public_html/back/alc/testcon.php on line 11
    back to drawing board


    Problem here is client's bangkok server has 4.1 mysql api (I checked actual phpinfo) and US servre has 3.29x

    How do I upgrade the mysql api? The mysql server is 4.1 on both servers
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Google and you'll find an answer to this question :)
     
  3. Secret Agent

    Secret Agent Guest

  4. Secret Agent

    Secret Agent Guest

    Anyone please?
     
  5. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India

    Hello,

    Please have a look at this link
    -------------------------------------------------------
    http://dev.mysql.com/doc/mysql/en/old-client.html
    ========================================
    Reset the password to pre-4.1 style for each user that needs to use a pre-4.1 client program. This can be done using the SET PASSWORD statement and the OLD_PASSWORD() function:

    mysql> SET PASSWORD FOR
    -> 'some_user'@'some_host' = OLD_PASSWORD('newpwd');


    Alternatively, use UPDATE and FLUSH PRIVILEGES:

    mysql> UPDATE mysql.user SET Password = OLD_PASSWORD('newpwd')
    -> WHERE Host = 'some_host' AND User = 'some_user';
    mysql> FLUSH PRIVILEGES;


    Substitute the password you want to use for ``newpwd'' in the preceding examples. MySQL cannot tell you what the original password was, so you'll need to pick a new one.
    =================================================================

    * From Mysql.com

    -------------------------------------------------------

    I had faced this problem before. I selected the third option at that time. I hope it will help you to solve your issue, Let me know the status ;)
     
  6. Secret Agent

    Secret Agent Guest

    Thank you but I think you misunderstood. I'm not having any problems with mysql itself, I just need to upgrade the actual MySQL API Client for PHP from 3.23 to 4.0 per customer's request. First time attempting this so I am not sure how to go about it.
     
  7. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    You need to go into WHM and when you update apache/php select "Use System Mysql".
     
  8. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    Recompile your apache
    ------------------------------------------------
    /scripts/upcp

    /scripts/easyapache and select the option 6
    -------------------------------------------------
    Let me know the status,
     
  9. rootuser

    rootuser Well-Known Member

    Joined:
    Jan 31, 2005
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    ***INDIA***
    That's great info bijo
     
  10. Secret Agent

    Secret Agent Guest

    The mysql client api in phpinfo still shows 3.23
     
  11. Secret Agent

    Secret Agent Guest

    Anyone know of any suggestions?

    Thank you
     
Loading...

Share This Page