The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQL Backup/Restore Problem

Discussion in 'General Discussion' started by derekivey, Apr 10, 2005.

  1. derekivey

    derekivey Well-Known Member

    Joined:
    Nov 30, 2004
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I am trying to move my accounts over to my new reseller and for the one reseller they were on, it added a bunch of stuff to the mysql backup and now I can't get it to restore on the new reseller. My other old reseller is fine though (I have 2 old resellers). It adds stuff like
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=19 ; Whats wrong with it? I also tried cpmove and it didn't work, the databases from the one reseller got to the new one but there were no tables in the new reseller.

    Thanks,
    Derek
     
  2. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    The mysqldumps have the MySQL 4.1 stuff in them. You're running MySQL 4.0 (or even 3.x?) and it doesn't recognize the extra stuff, so it spits out errors.
    You can either upgrade to MySQL 4.1 and then restore or edit the backup and take out the stuff the older MySQL doesn't support.
     
Loading...

Share This Page